Stop snap feature?

SketchUp is great but i’m hitting a brick wall with this (Sorry) idiotic snapping feature that i can’t seem to turn off.

I’m trying to size something and it just snaps where it wants to go, not where i tell it to.

Its really very frustrating, everytime you want to move or size something its just snaps around in huge chunks.
Its unworkable, i can’t move forward until i can get it to stop doing that.

any ideas?

Thanks. :smile:

PS: why does it even have this? in 3D creation the last thing you want is for it to chose where and how things should be, overriding your input.

On the model info window, Units panel, uncheck length snapping.


You can also retain length snapping but adjust the precision and format of the units, with means it will snap in smaller increments.

1 Like

Thanks but that didn’t work, i even tried zooming right in, it just snaps from one side of the screen to the other.

It sounds like you are trying to work at a scale that is smaller than your unit size and precision. Even with length snapping turned off, if you are using m with precision set at 0 trying to do anything shorter than one meter will be difficult as it will want to snap in 1m increments.
So check your units and precision. If that doesn’t fix it upload a model or at least a screen shot so we can see what is happening.

Its a ship, 270 Meters, trying to align images at scale, the side with the top so i can cut out a profile with the line tool.

It does seem to be snapping in 1m lengths, i think.

I worked out a way around the problem, i removed the template image and dropped it back in in a slightly different position, did that a couple of times until it was placed roughtly where its size would snap pretty much in line with the vertical profile.

Thanks guys.

Click … Window > Model Info > Units
There, try the settings shown below.

Keep in mind that whenever an operation in SU involves a unit of measurement it can be accomplished with accuracy via keyboard input to the Measurements Toolbar

This article… Measurements Toolbar Options …describes the many powers of the little box at located at the bottom of the UI on the right side of the Status Bar

1 Like

Its great this option… but its plain stupid that you cant stop snap to grid in 90 degrees or 180 degrees. it keeps snapping. Allot of programs use ctrl or alt so that when pressed they snap to the grid or snap to other points. This way it would be allot better then Always snap to 90 degrees or paralel lines.

Also an idea would be that like now snap is Always on until you hold ctrl or alt in which snap will be overuled and the actual position of the mouse pointer will be used at that time time until alt is released.

I really dont understand why this isnt allready in sketchup.

I think you don’t really understand what is already in SketchUp. Please re-read the earlier posts in this topic and read up in the knowledge center and see if that helps. SketchUp does not have “snap to grid” in any case; it has snap to length and snap to angle, but they are both relative to a starting point/orientation, not to absolute position/direction. And a value that you type in always overrides these snaps (typing a value is necessary to get it exact anyway). Also, SketchUp’s inference system tries to understand what you are doing and offers snaps and locks to many different kinds of points, lines, faces, etc - not just 90 degrees or parallel.

I think you dont understand what people are saying because you dont listen. Snap to grid is more a term for the mostly welcome but sometimes very annoying snapping to edges and lengths.

I dont want to turn it off because like i said it is most of the time a great feature. But like other people above allready mentioned is why isnt there a feature that when you hold (for example) ALT or CTRL that the snapping stops and you can draw freely until you release the button. This way you will have the best of both options. you can draw freely without the snapping when pressing ALT and when not it snaps like you would expect it to.

How hard can it be to implement this? I personally think its stupid that it is still not in the program. Now i sometimes need to zoom in insanely far to draw where i want it to.

1 Like

I’m curious how many accounts you plan on creating to say the same thing?

I’m having exactly the same problem.

have you found a solution to this?

it is extremely frustrating, when you import bitmap, and try to draw lines following curved line.

almost make me to want to put axe to the computer.

Precision box have to be at least on 0,00 to accept under zero snaping gap, this way you can freely move,
so as said “Box” on Dec’14:
“… retain length snapping but adjust the precision and format of the units,… means it will snap in smaller increments.”

If you don’t want snapping under certain circumstances, then you don’t want it to snap at even the finest of graduations. If you set precision to zero, then you are effectively switching off a very useful feature (snap),. but like many other people here, I cut my teeth on a simpler package that also used snapping - unless the Alt key is held depressed, in which case, it doesn’t snap. Even MS PowerPoint does that! Now I must state that I’m a VERY new user of Sketchup, and there are so many expert users that I can only conclude that there are ways around the snapping and that I will find, and get used to, at some point in the future - but for the time being, like my fellow sufferers above, I’m finding it very frustrating. The proof is that I’m here looking for, but not finding, answers.

This thread is under Technical Problems but the standard behaviour of SU is not that. The ability to turn snapping on and off easily, or indeed limit snapping to one mode, should surely come under Feature Requests. I would certainly endorse having more control over snapping if it can be done simply and lightweight.

I have this same exact problem. I imported an image I drew to convert into a 3D model and it keeps snapping to where I don’t want. I tried the suggestions above but it still does it. A keyboard command to turn off all snapping when pressed, but keep it when not, would be great.

What sort of image are you using? I do this sort of thing frequently–two different ones this morning, in fact. I don’t have any difficulty with unwanted snapping while tracing images. I actually like the snapping for helping with the getting endpoints where I want them. Different strokes, I guess.


The snapping is not getting the points, it keeps snapping to either side of the points in my drawing. I just want to turn it completely off so I can draw with the line tool where the actual points in the image are, not where it thinks they are.

If you turn it off completely, how will you keep points on plane?

Do you have Length Snapping enabled?

It’s disabled.