Disable this annoying new point snapping feature


#1

So essentially when I try to draw a line from the outermost point of a circle, after finishing drawing the line, Sketchup connects the line not to the outermost point I had wanted to put it on, but instead, the point left of it.

In the below image, I attempted to draw a line on the Red Axis, however the software moved it away from the Red, as you can see.

Is there any way to disable this and make doing actions like this function the same as in Sketchup 2014? Thanks!


Snaps to the wrong point
#2

This isn’t an annoying new feature. This happens when you are working at a scale smaller than the precision settings of the template you are using.

Go to Window/Model info/Units and turn off length snapping and adjust the level of precision.


#3

… and you should work at a larger scale to prevent other errors that will likely appear.


#4

From the screenshot it is not possible to tell whether the problems Box and Cotty raise are the cause of your problem, as nothing visible gives size of the model or units settings. It is also not possible to tell what inference engine markers you may have seen while you were drawing your line. So here’s an alternative explanation if you did not pay close attention to them.

If you move the cursor out from the start toward the desired corner, it will first pass close to the wrong corner and the inference engine will mark that corner. If you click while that marker is displayed, the end of the line will snap there. But if you continue to move the cursor out toward the other corner, the inference marker should eventually move to it. Then when you click, the line end should snap there.

As another technique, if you really want the line to be along the red axis, you could start it in that direction and then hold down shift to lock the direction while you continue to move the cursor to the endpoint. No matter where you click, the edge will be created parallel to the red axis.

By the way, nothing about this changed from 2014 to 2015.


#5

besides the described bahaviour :wink:


#6

Again, I don’t know the scale or settings in the original model, but I tried the experiment of drawing a similar line from the origin to a circle with 120 sides, with snap turned on at 1/2" and units resolution set to 1/4". I was able to draw the correct line every time, even though the incorrect corner was about 0.01" away from the red axis! All I had to do was pay proper attention to the inference engine’s hints.

So, I suppose to be grumpy, I still don’t see how the described behaviour locks down the explanation!


#7

You can tell SketchUp exactly which Axes direction you want to draw the line by using Inference Locking.
Then consider the Drawing Axes are infinitely adjustable. You control their precise location and direction.

The drawing axes context menu — SketchUp Help

Inferencing Locking


Axes Tool


#8

If you model too small, you will get the described error. You can try this with the attached model:
https://www.screenr.com/dYYN

smallgeoerror.zip (11.3 KB)


#9

Thanks for all of your answers, and in the end, I had to enlarge my model to preform the actions I needed to. I’m kind of surprised with this fix as my model scale wasn’t that small, and I’ve worked with much smaller scales before with no problem, but it works now, so I’m not complaining.

I should also note that I never encountered this with Sketchup 2014, so I have no idea why I’m only just seeing it now, if it was something occurring with older versions.


#10

Wow! I never ran into that one before, but I don’t ever model that small either. Thanks for enlightening me!


#11

This doesn’t just happen because both circle endpoints are too close for SketchUp, but because the new edge passes (or is supposed to pass) some endpoint at a distance (= measured perpendicular) that is too close for SketchUp. Any too close endpoint on the edge´s way to the target snatches the new edge to snap to itself. That is Any too cloce endpoint in the same (editing) context.

p.s. this can also cause problems of deformation of geometry when exploding a group or component. A straight edge might break into two or more pieces that aren’t completely collinear.


#12

Im also extremely annoyed by not being able to turn off inferencing. Ive even sent mails support asking for this. No matter what kind of model or settings the “new” inferencing is beyond annoying. For me its basically broken the program. The program keeps grabbing points or lines to inference from absoletly constantly when you work with so complex models as I do and it is absolutely infuriating.


#13

Somethings I have tried as a work-around is to have two instances of SU opened. One as a main or working model and the other to open a copy/pasted section, component or group into. This removes the other points the inference engine will pick up on / is trying to include. Modify or build the item, then ship back into the working model. Also working with layers you can hide other geometry creating the confusion.

And hiding a layer is different then hiding an individual item or group. As you don`t have to worry about geometry merging with a hidden layer.

It is part of the programs inner workings so you, like everyone else… have to adapted. After 2.5 years with this program I know what I need to do to work with it, instead of fighting it. And YES it does pissk you off sometimes. Just a suggestion…Peace…