Model lines off axis by 0.00001mm

Hi guys,

I have an ongoing issue with one of my sketch up models that all lines are constantly of axis by 0.0001mm and its therefore a pain to model inside the model and everything takes 100 time longer as I find myself remodelling walls all the time.
I have tried to fix this many times without any luck. Does anyone have an idea or is there a plugin which can align line with various axis?
I have attached two screenshots were it shows different measurements across different points on the line. Also the confusing part for me is that both lines are shown in red which means they should be parallel.

Thank you for your help.

This is the second picture.

Do you have length snapping enabled in Model Info/Units? If so, disable it.

Yes I have length snapping enabled with Pression of 1mm this is why I can’t work out how it’s possible for it to snap to 0.00001mm?
It’s very frustrating.
How would disable length snapping help in my case?

It won’t help your current issue but is the most likely cause of it.
Length snapping has often been found to cause these small errors because it tends to force an endpoint rather than let it snap to an endpoint. Once you have one error it becomes cumulative over the model.

1 Like

Untick the box…

Thank you for your help guys, much appreciated.

I’ve unchecked the box and spend about 3 hours to remodel a complete house and just right at the end the same mistakes keep happening that lines are just slightly of axis, which is becoming extremely frustrating. I really don’t know what else I could do. Every time I draw a line I lock in the axis with the arrows on my keyboard and even when I set style to colour by axis the axis would come up in green, red or blue but then it wouldn’t great a face as one line might be of by 0.0001mm.

Is there anything else I can try?

Thank you a lot!

Can you attach a model with the problem for us to look at.

The first house as the original one which I have many issues in it, then the second model was the rebuild of the first one however you can see that even there the measurements are off, then the 3 house I require to calculate the volume however somewhere there must be a break in it as sketch up can’t calculate the volume of it.

Thanks for your help.
Building Rev5.skp (11.1 MB)

I can see that there are errors but nothing is jumping out at me.
How do you normally draw, with the rectangle tool or the line tool?

I normally use a combination of both, depending on the situation. Do you know how I could fix the error that the volume is not getting displayed of groups, this would mean that there must be a gab somewhere in the wall or floor slab that sketch up is unable to calculate the boundary conditions of the shape?

I’ve just noticed your axis is off, right click on one of the colored axes and choose Reset.

There are a couple of leader texts that have encountered the singular text bug and flown off to Mars. That might be affecting your ability to place geometry accurately, as it affects the range of values SketchUp is trying to handle within finite precision. They also cause zoom extents to make the model seem to vanish. The bug was fixed recently, so I suspect you started this model in an earlier version of SU?

Here’s a version with these texts erased and also the axes reset per @Box observation.

Building Rev5.skp (11.1 MB)

Regarding the plain box version of the house, Solid Inspector 2 says there are stray edges, surface borders, and internal face edges. Examining them, it appears that they are all from situations where two edges are very close to each other but not the same. They border adjacent faces but leave a very tiny gap between them, which is why the group isn’t seen as a solid. I’m finding them very difficult to correct. Perhaps you should do the group over with those texts eliminated and see if that avoids your issues with precision.

Edit: you also have some edges and faces tagged. That isn’t the source of the problem here, but it is a practice that can lead to confusing issues in a model. Edges and faces should be drawn and left untagged.

1 Like

I didn’t even hit zoom extents, its usually one of my first checks.

Here’s a version where I managed to heal the boxy group. It required moving a vertex a tiny distance so that it aligned with those used by adjacent faces and then letting SI2 fix the remaining issues.

Building Rev5.skp (11.1 MB)

Thank you both a lot @slbaumgartner @Box
I have just installed the solid inspector, very useful tool, wish I would have known about this a while back could have saved me a few headaches.

Note that the source of your problems will not be solved by using ‘Solid Inspector’.
Start with setting precision to max and like @Box mentioned: disable length snapping!

Also note that ‘Color by Axes’ doesn’t always guaranty that edges are perfectly on axis.
They are either on axis or within the tolerance of the direction of axes.

Use ‘Color by Axes’ for modeling, provided that length snapping is off.

Note that @slbaumgartner’s corrected box still has at least one top face that is not entirely coplanar.

where do you find the setting for zoom extents?
Thanks,in advance

Found it, Thanks,