Snapping to origin


#1

I am fairly new to sketchup. I am drawing a house and my components are snapping to the axis when i move them. I can’t figure out how to stop this.


#2

Have you geo-located the model?
Or are you using geo-located components?
Are these your components or something you have downloaded?


#3

Also, are they dynamic components? If so they could be forcing values for their coordinates.


#4

They are components that were already in my library. I don’t believe they geolocated. And all I did was explode a component to use a piece of it. IE I am using stud walls and I wanted to use the 2x4 plate as a cca plate and change the color to green. But when I move it, it snaps to the origin.


#5

Why would I need to geo locate my model? I am not using an existing picture as my model.


#6

Why don’t you share a couple of the components that exhibit this behavior. Then we’d have a real hope of helping you solve the problem.

Every time in the past when this issue has come up, it is due to the components being geo-located or it’s a dynamic component with a setting as described.


#7

Maybe you don’t but that doesn’t mean the components aren’t already geo-located.


#8

It sounds like you have used part of a dynamic component that has been set to 0.0.0
But as Dave says, we can only tell you if you give us something to look at.


#9

Try this link. https://3dwarehouse.sketchup.com/model.html?id=ucbe1a7a9-6bbd-499a-af3c-52020ff0e930 I dont believe the problem to be with the component itself. I inserted this back into my model and did not have a problem. Just when I am using something from the preloaded sketchup library.


#10

I tried that 3DW model and had no problems with it snapping anywhere. Perhaps we need to clarify what you mean by “the preloaded sketchup library”?