"Snap" to guides not working (video example)


#1

I need to adjust the position of an edge. I have made my guide that is aligned where I need to move it, but the edge refuses to “snap” to it as I adjust it.


#2

Looks like a snap! Have you enabled length-snapping in the ModelInfo ? Window>Model info>Units
Disabling might solve your problem!


#3

disabling it did not seem to help unfortunately. it still moves right past the guide :-/


#4

You might wanna share the .skp file ?


#5

It has to be a snapping or precision problem.


#6

Here it is. It is the bottom of this corner that I was trying to get aligned on the green axis (the line is black, off axis). I made a guide for that green axis and dragging that edge just skips right over my guide instead of snapping to it.

image showing where the issue is. please CLICK the image to see the whole thing, because it is cropping off in this forum:

I was not able to post the images here because I am a new user


#7

I am wanting to move that blue vertical edge to the right, and get it to snap onto that black dotted guide on the floor


#9

You can upload the file itself here on the forum (seventh icon from the left) there is a maximum of 3MB but you can also share it via the 3D Warehouse


#10

You cannot snap to the dashed line (tail) of a guide point, as you have found out. SketchUp only snaps to that particular point. You’ll need an infinite guide to be able to snap to the dashed line.
There are extensions that convert edges to finite construction lines (dashed, dotted or whatever), not to be mistaken for your construction point with dashed tail. SketchUp will also snap to these finite construction lines.


#11

Once you select the edge, you will grab it from the bottom corner and drag it.


#12

It must be some VERY tiny incremental snapping I have on (because I am super zoomed in). I turned off the “length snapping” as a user suggested earlier but it didnt help. you can see that no matter what it “jumps” by these increments and avoids the guide


#13

Looking at your first screenshots I can only say that you don’t have a guide to snap to, only the “tail” of a construction point. Also see my post above.


#14

[quote=“elgrayso, post:12, topic:42630”]
… I turned off the “length snapping” as a user suggested earlier but it didnt help.
[/quote]You also need to set precision to 0.000000 to avoid any jumpy movements.
Length snapping (if turned off) gets as low as the precision is set to.
Length snapping (if on) jumps to what it is set to, thus either higher or equal to precision.


#15

How far from the model origin is the edge you are trying to align? When the move is very small compared to distance from origin I’ve seen cases where geometry won’t go where you want. I think it is an issue with communication between OpenGL, which will let you zoom in arbitrarily close, and sketchup, which may not be able to make a tiny change in a much larger value (it underflows).


#16

elgrayso; I suggest, you draw a similar drawing on a new page and then you move and look.


#17

I believe @Wo3Dan is on the money, or correct in other words. The guide to me is not infinite but only the tail of a construction point.

I had a frustrated guy the other day trying to snap to the same thing. I redrew some infinite guides for him and it worked right away, no settings changed in that case.

Edit: However, it shouldn’t be jumping around like that. I think others have covered that problem too.

Edit 2: I tried the below with length snapping on and off with similar results.

Note that if you create a guide from an endpoint or midpoint you will get a “guide point” with a tail, you cannot snap to the tail as shown. If you want a guide to snap to (infinite guide), create the guide from an edge (see the cursor text tips).


#18

So… snap to the guide-point itself, or onto the edge relating to that guide-point’s ‘tail’…
You can/'t expect to snap directly onto the ‘tail’ itself !


#19

thank you so much for that demonstration gif. That was totally it. I didnt realize there were “guide lines” AND “guide points”!


#20

Well, @Wo3Dan did spot it so credit to him too.


#21

This topic was automatically closed after 91 days. New replies are no longer allowed.