Cannot move guide line a precise distance from starting point

I’m using SketchUp Pro 2021, Version 21.1.332 on a Windows 10 64-bit OS. When I try to create a guide line using the specified distance option for the tape measure tool, as soon as I type any number into the measurement box, the line reverts to 0" and the guideline direction changes. Sometimes an error message pops up saying “constraint not appropriate at this time”. How can I fix this?

This isn’t a bug. It sounds like you need to increase Display Precision and likely turn off Length Snapping in Window>Model Info>Units.
Screenshot - 10_8_2021 , 1_45_15 PM

Please complete your profile wth the SketchUp version, operating system, and graphics card.

Thanks, Dave, I really appreciate your quick response, and request. I will update my profile.

I tried the solution you recommended, making sure length-snapping was unchecked and set to fractional precision of 1/64. No joy. Thoughts?


Share the .skp file. How far are you trying to place the guideline from the reference line?

If it’s less than 1/64th in. maybe you should choose a different unit.

Here I’ve dragged a guideline off from the reference guideline by less than the diameter of the average human hair.
Screenshot - 10_8_2021 , 2_34_50 PM

If you are clicking in the measurements box first, don’t! Just let go of the mouse and type the value. It will pick up in the measurements box automatically.

1 Like

Steve makes a good point. It crossed my mind to mention it but I thought you’d been using SketchUp for a while aready and would know not to do that.

Thanks for the suggestion. That’s what I’ve been doing. No joy.

Precision only affects the numbers SketchUp shows to you. Inaccuracies are rounded and hidden.

Here’s the .skp file: top with surfacing and substrate 20211007.skp (90.7 KB)

I’ve used the method Steve suggested for years, without problems. Perhaps the solution would be to uninstall/reinstall?

Perhaps I should uninstall and re-install.

Not yet.

Thanks for your comment, Anssi. I switch back and forth on units and precision as the design warrants. What you describe is what I’ve always seen. I think the issue isn’t with precision, but perhaps Dave’s illustration offers a potential pathway – i.e., making the precision microscopic. I’ll give that a try…


Where are you trying to place the guideline and at what distance?

FWIW, I see you have Display Precision set to 1/32".
Screenshot - 10_8_2021 , 2_54_29 PM

I always model with Display Precision set to the highest available for the units I’m using. That makes it possible to see odd dimensions and deal with them before they create problems. I don’t intentionally model woodworking projects with dimensions in 64ths of an inch but my Display Precision is set that high.

In the skp you’ll see a frame I’m designing, using milled lumber. I want to divide the distance between the interior edges of the end cross-members into three, so that the two middle cross-members are evenly spaced across the length of the frame.

Did you upload the right model? All I see is this.

No frame.

1 Like

Yes, me too. I usually set the precision to fractional 1/32 because that’s the smallest dimension I can measure. If I’m being really precise, I go to digital with four-place accuracy.

I use higher Display Precision than I can measure in the shop. Again I do that so I can see discrepancies.

My bad. Here’s the correct file:outfeed table 20211002.skp (68.4 KB)

Good suggestion!

I assume you realize that the units precision setting affects only how values are displayed on the view, not the actual granularity of the values?

I do, Steve. Thanks.