Not snapping to guides

New here and hoping for some help from someone with a lil more experience than me.

I’m having a hard time being able to snap to my guidelines. I’ve imported an acad file, created some walls, and now trying to punch in some windows. After I draw guides on the elevation often when I try to use the rectangle tool it doesn’t snap to an intersection point. Strangely this morning it is snapping but now when I try to push a rectangle through it doesn’t penetrate fully.
What am I doing wrong here? What are reasons it wouldn’t be snapping nicely? Driving me nuts.
Thanks in advance.SketchupHelp.skp (1.6 MB)

In some cases like this one, you could do this

1 Like

Your guides aren’t flush with the face that they are supposed to be on.
Their intersections are 4.676300mm “above” the inner wall face. Pull the rectanglular face to the inner wall face, only then towards the outer wall face. These two operations will create the desired void.


Illustrating @Wo3Dan’s point:

1 Like

Thanks for all the speedy replies. I thought it may be something like this…
What are some reasons why would my guides not be on the exterior wall surface? I’ve initiated the guide from the interior edge of the face where the opening would go.

One key possibility is that you have Length Snapping enabled in Model Info>Units. Historically that has cause problems for many users. Best to disable it.

1 Like

I am not sure how you put the guides in, but they are not actually on the walls. the rectangle you drew is 3/16" away from the face of the wall.

For the vertical guides, I’m selecting the interior edge at the corner of the room and then moving it across the wall.
For the horizontals, I select the edge at the intersection between the floor and the wall and moving it up a desired distance.

Have you turned off Length Snapping as Dave recommended and tried that again?

Yeah, thanks. I had the same result though. Like someone above suggested, I drew the rectangle and push/pulled it to the inner face and then pushed to outer to get the opening. It worked. It’s a bit annoying to have to go thru the extra step but until I can figure it out I’ll use this method.

Thanks for all your time.


How do you list the coordinates at points? Thanks

Use the text tool, click on a vertex and move away.

I zoomed in on the inside corner and found this:

Screen Shot 2020-10-09 at 10.33.45 AM

You have a line just a bit away from the bottom corner inside the floor group.
I am guessing you started by pulling a guide off this corner, and the rest just stayed in line with that first one.

I would also recommend working in Perspective mode with X-ray turned off. The view that this model is saved in makes accurate line works quite difficult.

Great eye! Thank you. :beer: