Slow rendering 940MB file with Vray

Guys Need help

I have purchased HP Z6 G4 Workstation with Quadro P4000 but my system is slow when it’s rending with size 950x534 which takes 36hr to complete it.

I have attached some screenshot which you all get some info of my system and guide me on how to upgrade to make my render faster and smoother.

It will be more helpful from your side.

3|690x388

The components are quite good as far as I see. And 64 GB of RAM is waaay too much. You shouldn’t have any problems. Can I ask you how many Mhz does have the memory RAM and the DDR type?
The rendering time is sketchUP is affected by how many polygons and textures the model have as well as how many scenes are yet to be rendered and the time per each scene. But the CPU looks more than capable for this kind of deal, even though the CPU base frequency is 1.80Ghz which is a bit low. Indeed the CPU has 8 cores and possibly 16 threads but still, but for an optimal workflow a 3.0Ghz base frequency is required. About the GPU, I don’t have any experiences with Quadro but from few benchmarks I ran, it seems a quite good video card for 3D design. As far as I know and correct me If I’m wrong, sketchup makes use mostly of CPU and RAM and much less of GPU.
Can we see the model you are trying to render?

when seeking advice on third party rendering it is quite helpful if you tell us which renderer you are using…

john

2 Likes

Thanks for your reply and i can send you my file to you to check where i went wrong.
Kindly check my file and let me know it and if possible can you can send me some preset for vray 3.4 render.

File: https://we.tl/t-gpavXtRcc6

I use SketchupPro2018 with Vray3.4

I can’t check it right now but I will as soon as I get home. I did opened the link and I saw the file has 894MB, which is alot. I wonder what does the model contains :slight_smile:
Personally, I am not using using Vray and I can’t help you with that but I think I can help you to optimize your skp file abit if my computer will Be able to run it :slight_smile: I’ll give it a try.

21:58
P.S: I’ve downloaded the model you gave us but to my shame, I can’t open it :))
My PC is a trash but even though, 894MB is too much for SketchUP to handle. If anybody with stronger computers can run the model would be great.
I’m very sorry but I can’t help you as my hardware keeps me down.
My advice for making the render time shorter? Try to make a smaller scene, add details only in the field of view, make the objects components if they are created by you, purge unused materials (go to the right bar with materials and click the “In Model” icon [Home like button] then click the black arrow - purge unused), purge unused components (View/Animation/Settings/Statistics/Purge Unused and Fix Problems) and consider upgrading the CPU with another one with a larger base frequency. Perhaps using a third-party rendering engine would be the most convenient thing if you have large, outdoor landscapes with tiny details. Try to post a thread on vray forums as well. That’s all I can do.
Good luck!

Post withdrawn

No amount of fancy hardware can overcome poor modeling technique.
Spending even more money to upgrade the system will have no benefit.

See this compendium of performance modeling tips.


1 Like

Your file is HUGE by SU standards.

Over 23 million edges, almost 14 million faces, file size almost 940MB.

ANY computer will struggle with this large and complex a SU model.

Most of the fabric is over-detailed, with more faces and edges than is needed to render smoothly.

Look at this monochrome view of part of the sofa, with hidden lines visible:

And one of the flower vases:

And too many reversed faces (showing dark blue/gray) including almost all the flower petals here, and the background of the latticework panels in the background .

You could get a model that would render equivalently with FAR fewer edges and face.

That kind of thing is what is slowing down both your modelling in SU and even more, the rendering.

There are some plugins that can help simplify over-detailed geometry, or you could learn to draw them yourself more simply.

Or use the tips in the previous post to simplify your model.

Did you import the components from the 3D warehouse? Many examples there are like this one - vastly over-detailed to no useful purpose. Usable, perhaps, on their own, but too much detail to be readily usable as a small part of a larger model.

Before incorporating them in your model, it is always worth downloading each into a separate SU model, to check if they are over-detailed, and for you to try to simplify or redraw them. Or find less elaborate equivalents.

2 Likes

I suggest you invest in SKIMP immediately! (No affiliation - just that it does the job!)

1 Like

Thanks for the support but these model i converted from 3dmax and sometimes i use cleanup plugin to reduce my size of file almost it removes some hidden geometry

Thanks geo, Its so help link you have shared it.

Thanks John, i do get your points but there should be some setting in vray Render to reduce the time and give best result.

Hello, no need for skimp nor reduce the number of polygons, you just need to convert your large detailed objects to proxies in the vray toolbar. that way in the viewport these objects will be replaced by a box or whatever you want them to be instead, and vray will still render the original object.
Geometry won’t have a lot of impact on vray’s render time, but too big textures will, so will they if they have displacement in their parameters. Remove displacement if you have on some of your texture and try again

Also check if setting the GPU for rendering instead of the (default) CPU improves anything

You should check your conversion parameters - the created meshes can be much,much more coarse than what the conversion now produces. 3DSMax surely has some controls over mesh resolution.

Y0ou can also check out Transmutr. It can reduce geometry and save ‘heavy’ components as VRAY proxies. Rule of thumb is that when your model begins to climb over 2+ million polygons things start to slow down. Layer and scene management can help too. Try hiding or putting objects that are not visible in your Render scene on a frozen layer to reduce what SketchUp has to actively display. Or consider breaking your very large model up into several smaller ones if you have have more than one view.

1 Like

I have only 16GB on my computer, your scene after loading gets something like 42GB uncompressed.

I was not able really to operate over scene in SketchUp, I just managed to change one material into light type, as you can see from the render the wrong one…
But this render took only 10 mins (8 mins for export because of SSD usage for virtual memory).

If you have 64GB machine you can try it (there is free test version with resolution limit):
www.brighter3d.com

Or you can try first transmutr as eric-s suggested, to make your scene simpler

444