SketchUp V-Ray rendering a scene for 15 hours / Please help / Interior design student

Hello :slight_smile:
I need help with my SketchUp V-Ray settings. A medium quality 2D picture renders for approx. 15 hours (!!!). An example is attached [1_SCENE_EXAMPLE.png , 2_RENDERED_PICTURE_EXAMPLE.png].
I use the best settings I was taught but I am sure that I am doing something wrong - some people with considerably worse PCs render better pictures in an hour or a few hours. I attach screenshots of all important settings - please have a look and help me how to shorten my time of rendering [3_SETTINGS.pdf].
I am sure it is much easier just to open the file and have a look so I attach my project in .skp file format [4_PROJECT.skp].
The pictures are going to be printed on a 100 cm x 70 cm format. They are a part of my studies (interior design) so it is very important for me to improve their quality and rendering time.
PS: my PC parameters should be good enough to perform such a render in a shorter time:

  • CPU: IntelCore i5 1.8 GHz,
  • GPU: Nvidia GeForce GTX 1050 with Max-Q Design,
  • RAM: 16 GB.
    Because I am a new user I cannot attach more than 1 file so all files are in the link below:
    SKETCHUP PROJECT - Google Drive

There are some things you can do in the model to help. First, you have a lot of reversed faces. You should correct them so only white front faces are exposed.

It would also help to clean up the model and reduce the unneeded large texture sizes. That simplified the model and reduced file size by about 48%. You could simplify this model even more by eliminated unneeded stuff like the boxes for the can lights.

I expect @mihai.s might come along with some more Vray specific hints but I would suggest fixing the SketchUp model first so it is clean and actually read for the renderer. Going forward you should be ensuring that the geometry is correct before you start applying materials. It’s a whole lot easier to keep the model clean and correct as you go than to fix it all later.

Here’s the purged model. You’ll still need to deal with the face orientation. I didn’t remove the materials. I just changed the style to Monochrome. You can edit the style again to see the textures after you’ve corrected the face orientation.

First of all, create your model correctly (Dave has already shown you what and how).
Try reseting your V-Ray to default settings and turn off ‘Progressive’.
Choose Cuda instead of CPU.

Few minutes at 3k

1 Like

You can try real time rendering engines or software, like enscape, twinmotion, D5 and lumion, I personally recommend twinmotion and D5, both have free versions with almost no limitations, they’re also very intuitive. Enscape is also great and it’s easier to work from skp since you have to export your model to work with the other engines. Lumion is a good software but they’ll probably disappear cause they have direct competition with a lot cheaper prices or even free, paying 2000 for this software isn’t worth it any more.

@DaveR thank you very much for reply and given help. Could you explain me some details? I am a girl and I am not so familiar with some technical issues in SketchUp.

  1. What is the difference whether the front face is white or dark? I put the textures on a particular side (it can be dark as well). I don’t understand it but of course I followed your advice and used the “flip along” tool to reverse the faces.
  2. How do I reduce a texture size without quality loss? I download dedicated textures from sketchuptextureclub.com and their quality is good. Could you explain me how you reduced the file size by 50%?

@mihai.s thank you for your advice. I reinstalled my NVIDIA drivers and changed my settings to CUDA, progressive off and medium quality. However, the render still took ~3-4 hours to take. Is it normal that in task manager my GPU is at about 7% usage during the render while CPU is at about 90%? I think that something still might be wrong.

Could you guys have a look at my project (I now work basing on the purged version sent by @DaveR ) and tell me if all my settings are ok? The render of scene 2 as well as scene 3 took 3-4 hours for me. Could you try to render them and try to guess why it takes so long (I think only for me)?

Thanks, thanks and thanks again for your help! :slight_smile:

Sketchup has a default color for faces, white is an outside face and the bluish gray color is for inside faces, if you model a wall or a cube all the visible faces must be white, if you delete a face you’ll see that all the interior faces have a different color. Some times due to different factors it’s possible that you end up with faces in the wrong direction, it can affect when you render, the faces in the wrong direction could look weird, and the UV mapping will also be wrong.
To reduce the size of a texture you can use any image manipulation software and also I the sketchup preferences select to don’t show images to a high resolution, if you import them to the viewport and use it with the paint bucket and the drop tools.

there is a nifty extension, it’s free, it’s from sketchup.

in the extension warehouse, look for “Material Resizer

Here is a video showing how it works, basically it’ll check all of your texture files, and allow you to simply select some (the big ones) and give them a smaller dimension. simple as that.

you won’t gain lots of weight immediately, a 2000px 4mb image will become a 1000px 1mb image, but still, it adds up. a mb here, a mb there…

edit : SUtexture club had good images indeed. The issue you’ll face is that at times, it’s TOO good for what you use it on.
If I use a 2000px image for a brick wall, it’s good. if I use a 2000px image for a door handle, it’s a bit much. Both have the same resolution, both looks good, but one could actually go down to 1000px without visible degradation. Hence material resizer :slight_smile: