Slow performance with SketchUp Pro 2015


#1

I have had repeated issues with performance with SU 2015. Seems to vary with each model I work on but normally there is some serious lag with being able to move or edit object and components.

I have a Mac Pro OS 10.9.5, with 32 GB of Ram and a 3.7 mhz Quad-Core Processors.
Video Card:
AMD FirePro D300:

Chipset Model: AMD FirePro D300
VRAM (Total): 2048 MB
ROM Revision: 113-C4012F-687
gMux Version: 4.0.11 [3.2.8]
EFI Driver Version: 01.00.687

All shadows, profiles are turned off, etc and still have performance issues.

I am currently working with a file that I have at least 10 sec lagtime between every click. The file is 11mb. The Model info is below.

Edges 2722528
Faces 724331
Component Instances 37362
Guides 2
Guide Points 8
Groups 2299
Images 0
3d Polylines 0
Section Planes 0
Dimensions 0
Text 0
Component Definitions 45
Layers 2
Materials 70
Styles 1


#2

what active plugins are you running?


#3

Also, do you have the outliner window open? It is known to slow SketchUp dramatically.


#4

I have Podium and that’s it.


#5

I never have Outliner open.


#6

Podium will be re-evaluating each of these for changes frequently. If any are large that will be extra time…

If Orbiting, Moving or AutoSave kicks in while that’s happening, historically it could crash SU [ that may have been fixed or improved…]

it is also possible for a material to become corrupted if the activities clash…


#7

Interesting so Podium runs actively before you export to render? I didn’t realize that.

Is there any way to check if a material is corrupt?

Thanks for your input.


#8

It is a while since I stopped using Podium, later version may be less inquisitive…

most renderers use observers that will start when you open SU, this has always caused issues on mac’s, IMHO…

They want to keep tabs on your changes so that they appear faster when you click the go button…

I normally, disable them until I want to render, and never with AutoSave or make Backup enabled…

If the material is corrupt, the skp will be broken, as it’s in the file…

You can use the Goldilocks plugin to see if the materials size is ‘just right’ and not ‘too small’ or ‘too big’


#9

Your model, too, is very heavy, with more than 2 million edges. You seem to have a lot of polygon-heavy components, as the file size remains reasonable at 11 MB. That is why file size is a poor indicator of a model’s performance, what counts most is the actual count of edges and faces your computer has to process. Large textures are often blamed for causing performance issues, but most of the time they do not slow down performance significantly. Note that when you zoom or orbit, the work is divided between your graphics card and CPU so that raster effects like textures and shadows are processed by your graphics card, and faces and edges by the single processor core in your CPU that SketchUp uses. That is why, most of the time, using an image or texture is faster than representing the same thing with 3D geometry.

Anssi


#10

Thank you for the insight. I am using some Organic shapes ie. trees so that would add a lot of polygonal faces. I will try to remember that moving forward.


#11

There are also plugins that let you use simpler “proxy” objects while building your model and then swap them for the detailed real ones when you are finished. For example

http://sketchucation.com/plugin/772-proxy