Slow performance SketchUp Pro 2019

Hey there,

I just got a new Dell G5 laptop 9th generation CPU and graphics card GeForce GTX 1060 with Max-Q.
While 3D modeling in SketchUp Pro 2019 my laptop gets really slow and often crashes. It happens as well with AutoCAD drafting-it gets really slow, but doing renderings with V-Ray is fine.
Do you have maybe some suggestions about how to improve the performance?
Thank you!

There’s a lot of useful info on the subject here…

1 Like

Forum Searches:

1 Like

That should run SU as smooth as silk! Something IS wrong somewhere. Since both Acad and SU are having issues it might bad hardware, yes it happens. I’d do a RAM test myself just to eliminate that.
My home box, 4th gen i5, 12 gb ram, 512 sata ssd and GTX 650 ti has NO issues with SU 2019 or Acad 2020.

… and make sure SketchUp is running on the GTX 1060.

Inside SketchUp … Window > Preferences > OpenGL > Graphics Card Details

1 Like

Very true but Acad should run just fine with an integrated graphics while drawing in 2D. Something is wrong some where. I bought my one son one of these laptops last year and his runs anything he throws at it, acad, fusion 360 and su (he’s in mech eng technology in tech school).

One of the first things to check would be that your Nvidia driver is up to date.

1 Like

Or you might have to roll back to an older one, it can happen.