Slow opening drawing and very slow after my drawing size increases

I am using sketch-up 2022 in my thinkpad t460s and cant open my drawing fast my drawing size is 60 mb and I cannot edit my drawing due to slow application
Help me

I expect it’s over-taxing your computers resources including the integrated graphics. Can you upload the SketchUp file to a sharing service like DropBox and share it so we can see what you are working with? Might be possible to make it more streamlined and improve the performance.

Well, I have never made a model that large. Have you purged it? How many edges/faces (with components included)?

How to check total edges faces and how to purge it

Window>Model Info>Statistics.

I7 6th gen
Intel graphics 520
12 gb ram
256 ssd

Integrated graphics processor.

Integrated GPUs have never been recommended for use with SketchUp due to inadequate OpenGL support and because they have to use shared memory. Your large file is probably overloading the system slowing things down.

As I asked before, share the model file. I expect we can give you some guidance about improving your modeling to limit the performance problem you are having with your computer.

Crossed posts.

The main issue is with unused stuff. I fixed the incorrect tag usage…
Screenshot - 3_30_2022 , 9_16_56 AM
That might have come in with entourage you collected from the 3D Warehouse.

And I purged unused stuff.
Screenshot - 3_30_2022 , 9_17_33 AM
This reduced the file size by about 34%.

There’s more that can be done to speed things up. For example you have multiple faces on the floor in the computer room. Notice the Z-fighting there in my previous screen shot. Lots of reversed faces which won’t affect speed but ought to be corrected.

Turn off Profiles in the style so you don’t have to wait for the graphics card to calculate which edges should be profile edges and which aren’t.

Screenshot - 3_30_2022 , 9_23_54 AM

There are lots of edges in repeated objects like the keyboards. Those could probably be simplified using an image of a keyboard as a texture instead of having geometry to show the keys.

1 Like

Can you help me and teach me by screen share or by skype calling

Why the tutorial on youtube and udemy don’t teach this

I’m sorry. I can’t do that right now…

I will show you the following but then I have to get back to my regular work.

There are tiny little stray edges out away from the bulk of your model. Open the group for editing and erase them.

1 Like

A question I’ve asked many times.

I suppose because it isn’t glamorous or anything.

1 Like

Please give me at least some time not today as your wish please teach me some tips and lessons

You also have Hidden Geometry and Hidden Objects turned on in all scenes. That won’t speed things up either.
Many of your entourage components are way too detailed, like the computer keyboards with all the letters as vectors, and the computers with their extremely detailed front panels (BTW, who, today, even has a DVD drive, or two), just to give some examples. Both would work quite well as black boxes with an image on front, like the measuring instruments you show.

1 Like

There are 18 lakh edges and 8 lakhs faces