How can I speed up SketchUp?

Hello All,

I’m running into some speed issues with SketchUp… I spent the last few days importing some pretty intensive Revit DWG’s and now SketchUp is running ridiculously slow for my computer’s specs. I’m currently working on a new building, also a Revit DWG, that our company is planning on renovating and eventually moving into. It’s all new construction so we’re getting in now so that the Execs can see the space and have a bit of freedom to redesign the internals if necessary.

Anyways, the Revit file is only 49 MB which is in huge contrast to the 870 MB Revit file I was messing with the other day. I’m running a 7700K with 32GB of RAM and a GTX 1080 Ti so my computer should be able to handle this relatively small DWG really well.

There are a lot of lines from floorplans and the site info but my export method creating a 12 MB DWG and it imported in about 15 minutes. However now that I’m running various cleanup plugins and trying to navigate the file any click takes an unusually long time to process.

My question is: is there any sort of cache or library that I need to clean out for SketchUp to perform better? I ran into some speed issues with another Autodesk program and merely uninstalling and reinstalling fixed those right up so that’s definitely crossed my mind.

Any ideas?

Thanks,

T.

How big is the SkUp file once the DWG is imported? Window>Model Info>Statistics to find out how many lines and faces you’re dealing with. Post a screen shot of that to get feedback on how big is big. The cache of sorts is purging everything unused so that it is really removed from the file. And layering so you can control visibility and give OpenGL a fighting chance to keep up. Some more good general advice below.

I have had big DWGs clog up sketchup before, had an arena model that pretty much broke it, 300+ mb. I ended up cutting the model into quarters and working on 4 separate files. There have been a few moments when copying everything and pasting into a new window has seemed to yield some improvement but I can’t justify why that worked, could have been a one time corrupted file.

My guess is that you have an Intel graphics card and there is a problem with a recent update. Try rolling back your driver.

endlessfix,

The model is only about 115 MB. I’ve worked with 350 MB files before and yeah they’re slow but even they were faster than this file. I can turn the furniture off and it runs pretty smoothly so I guess that’s my current workaround. They’re all manufacturers models so the furniture is pretty intensive.

I currently have another SketchUp file though that is 65 MB and it’s the real time hog. There are a lot of groups so I was going to go through and do some intensive and selective exploding of walls and such to regroup things. My coworkers have been messing around with it though so I haven’t touched it in a few days.

Neil,

I’m running dual 1080Ti graphics cards with a dual monitor setup so each card has it’s own monitor. I will double check the graphics drivers though see if anything improves it.

Thanks,

T.

did you have imported the DWG with the option to keep the (maybe very far; e.g. Grauss-Krueger coordinate system) drawing origin?

if yes, move to the model space origin or import again with this option above unchecked.

More info on this in the concerning help center article.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.