Sloped wall

Nathalie’s floorplan help.skp (271.7 KB)


SketchUp newbie here. I’m going a bit insane trying to figure this out - in my 3D model, why has only one door pushed right through and not the other door / windows? It wont let me push right through to make an opening?

Secondly, you will see from the file on the long wall (no windows) - I’m trying to slant the wall from 1001mm from the ground. So it’s straight up for 1001mm and then slants to meet near the windows (it’s a loft room) - for the life of me I just cannot get the top half to slope/ slant. Please help?

Thank you!

Push/Pull: It looks to me as if you just didn’t tell SketchUp when to stop pushing. Start pushing and then click on the opposite edge of the wall. After you do the first door, you can double click on the second one. SketchUp will remember the Push/Pull distance and use it again.

Can you show some sort of sketch that shows the slant you are trying to create?

If You’re pushing through something snap to the face you’re pushing towards and it’ll create the opening.

To slant the wall use the tape measure tool (T), measure from the ground up, type in the 1001mm, create a line and then use the move tool to pull the upper part towards the openings.

Hope this helps. :slightly_smiling_face:

Hi there,

Thank you so much for this. I managed to slope the roof.

For some odd reason or another - the other door and windows wont snap through though, I’ve tried a few of the options above - the one door is fine as I did it a while ago but the other door won’t work. The windows wont push right through even though I snap to the face i’m pushing towards.

It’s also looking a little crazy on the exterior outside the double windows and sloped roof. Do you recommend I just start again? I was trying to bring the sloped roof inwards so there is less of a flat part on the roof and just the thickness off the wall.

Again, really appreciate your help! I’ve been watching all the you tube videos but can’t quite figure this bit out

Nathalie’s floorplan help3.skp (264.3 KB)

I presume the attached pic shows where you hit an issue. I turned on xray to show inside the wall and also selected the edge above the door without opening the component for edit. This shows two issues: there is a diagonal edge inside the wall that I’m sure interfered with your push pull attempt, and you have drawn an edge at the top of the wall outside the context of the component. The second is probably not relevant to your issue, but is also probably not what you wanted. Erase the non-component edge, open the component for edit and delete the diagonal. Then you can push pull the outside of the door back in place and delete the face it leaves (because you already pushpulled it past the outside of the wall it will no longer automatically cut an opening).

Yep, moving the face of the outer wall really messed things up, your model also has a lot of faces that are reversed - you can see them in blue. You can right-click them and reverse them (so they’re white/gray) and eventually fix all the faces. I fixed it up real quick for you.

Nathalie’s_floorplan_fixed.skp (266.6 KB)

You might want to check out the Sketchup Basics page to further get into Sketchup basics, there’s also a whole bunch of Youtube tutorials on how to properly get started.

Thank you so very much! I really appreciate this. Im going to keep pushing on with the tutorials. Thanks again for cleaning my plan up.

Thank you! I think things got a little crazy so I’m going to start over.