SketchUp won't start with selected template

templates
mac
sierra

#1

I have selected a template to start with but for some reason, each time I create a new document, sketchup starts with a different one. How do you make sketchup stick with a given template?


#2

Have you tried selecting it from the system preferences (found on window/preferences)?

Unfortunately that’s the only thing I can think of, I have no clue on things working on mac.


#3

On Mac, click SketchUp - Preferences then choose Template from the list on the left:

This will show what your current Template is, and allow you to select a new one.


#4

I’m using a 2015 version of Pro with intent for the first time, not being experienced with Sketch Up anyway:

Although the default template should give the model metric units, it remains in imperial units for some mysterious reason. I’m on a Mac running 10.10.5. This sounds a bit like the problem you were having. Any advice welcome. Thanks


#5

Is this a question you can answer? It seems not to have gained anyone’s attention yet.

The topic was a year old, so perhaps no one is looking, or interested?

Excuse my ignorance, but by replying to a member’s post, everyone can read my question, but that member gets a notification?

Thanks


#6

to the question about getting notified, yes, I got an email


#7

I’ve just installed 2018 and I have the same problem - I create a new template and make it my default yet it fails to open with the new template - can anyone tell me what’s going on.


#8

Did you install SketchUp correctly? That is, did you right click on the downloaded installer and select run as administrator?

What exactly did you do to create a new template? When you saved it, did you make sure the Use as default box was ticked?


#9

Yes - I installed it as administrator - I saved the template as my metric and it appeared in the preferences page as my metric and as the default.


#10

I’ve just re-installed it, setup my trays etc and saved as template which it confirmed. Closed the program and reopened - no joy!


#11

I’ve now discovered that on a fresh re-load from a new installation under preferences/files/templates is deselected and shaded out.
why?


#12

It’s grayed out because that is a fixed location that isn’t user-selectable like the other other ones are. There isn’t anything to make it selected or deselected.

Screenshot%20-%209_14_2018%20%2C%206_37_27%20AM

What do you see if you click on the folder icon at the right end of that line?


#13

I see my my metric file.


#14

Close SketchUp. Find the file called SharePreferences.json and delete it. It should be in C:\Users\YourUsername\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp

Then reopen SketchUp. You should be able to select your template from the Welcome splash screen so you don’t need to make it again.


#15

I can’t find it - my users doesn’t have a roaming app data file which has me confused.


#16

It’s a hidden file. You need to make it visible.

See this if you don’t know how to do that.


#17

Thanks Dave - I’ve made files unhidden and found that file and erased it but I still can’t save a template that stays when I reload. and the SharePreferences.json returns


#18

That is expected to happen. The idea of getting rid of it was to make SketchUp create a new one.

What template is SketchUp starting with if it’s not your custom template?


#19

It starts with the green ground and the lady standing there


#20

What are the units set to?

What did you do besides changing the units to metric before saving it as a template? How about uploading your template file so we can see it.