SketchUp won't start Dell D6000 Docking Station

I have a Dell XPS 15 790 laptop running windows 10 home edition, 64 bit, w/ 32 GB of RAM and a Nvidia GeForce GTX 1650 graphics card. I use a Dell D6000 dock to run a 32" LG 4K monitor. SketchUp Pro 2020 will launch and operate, but only on the laptop (it will not launch at all when I am plugged into the D6000 docking station to run the large monitor). This is very annoying - any assistance would be appreciated, thanks.

Many dock types, especially older ones, seem to have this kind of problems. Here’s what I found on the Dell community forum:
https://www.dell.com/community/Laptops-General-Read-Only/Latitude-E5570-D6000-dock-3D-Hardware-OpenGL-issues/td-p/5171483
I would say that the long and short of it is that you should update all related drivers and dock firmware etc. and if it doesn’t then work you may be out of luck. I am not quite sure from the specs I found but it might be that your dock doesn’t support the Thunderbolt connection in your computer. My work computer connects via a Thunderbolt dock (HP) and for me OpenGL apps work OK (finally, after updating everything). Also, the cable you use to connect the monitor to the dock might matter.

Anssi - Thank you for the reply. I tried updating the docking station’s drivers to no avail. My laptop does have an HDMI out connection - using this for connection to the second monitor (bypassing the docking station completely) has solved my issue. Thanks.