Sketchup won't install, ThumbsUp.dll failed to register HRESULT-2147024703

win10
installation

#1

Upon trying to install Sketchup it encounters an error every single time, stated in the title. I’ve restarted my PC, redownloaded the file a few times and tried installing it as an administrator, all to no avail.

I’m running Windows 10 64bit with an Nvidia GTX 680.

I really need to get this program up and running so if someone could help me It’d be greatly appreciated. I’ve been messing around with it for almost an hour now and I can’t think of anything more to do.


#2

Windows 10 is not yet officially supported by any of the SketchUp released versions (as they all were released long before Windows 10 was.)

See:


Are you installing from a normal account or an administrator account ?


Do you have any AV utility running ?

  • If so, what is it ?
  • Can you temporarily switch it off while installing SketchUp ?

#3

While you’re at it, update your graphic driver too.


#4

I’ve been thinking this might be an issue, since I can’t seem to install any video drivers anymore. Geforce experience can’t properly download drivers, and when I download them from the Nvidia website they always result in a failed install. I’ve completely wiped all drivers and Geforce experience installs before and reinstalled them but it still doesn’t work.

Maybe my windows is just borked and I a clean install is the solution but I hope not.


#5

Try uninstalling the drive and reboot the computer. The driver comes through a .EXE file. R-click on the EXE and choose Run as administrator.


#6

… reboot until only the generic Microsoft Windows video driver is active,… only then install the Nvidia driver.