Installation cancels

I am a new user and have tried multiple times to install Sketchup. Everytime I run it as administrator it cancels. I am running Windows10 64 bit. I have a screen shot of the problem but no reason is given for the cancellation. It just says to try and install it later.

Hello! Just a shot in the dark, but have you checked your disc space? Also, have you tried running it without administrator privileges?

It passes the “computing space requirements” phase so I imagine I have
enough. I have 880gb available on the drive so I do not think that is the
problem. I do not install to my C drive though since that is my solid
state drive and is used just for my OS and frequently used items. Could
that be the problem? does it insist on being installed on the C drive?
ps thanks for the quick response

Mine is installed on D disc and runs just fine, so I guess there probably shouldn’t be any problems.

Thanks for the information. I did not think that would be a problem since
the setup program gives us the ability to change the install drive. So I
am out of ideas then and unless someone has a similar problem, I will just
have to use a different program.

One of the most critical bits of hardware for SU is the graphic card. You only have a question mark in your profile for that.
Many many installation problems are from incompatible or outdated graphic cards and their drivers.
So help us with a but more info if you can.
What card do you have?
Have you upgraded to Win10?
What is the actual error message? Sometime people paraphrase and the important bit is missed.
That’s a start.

problems with the OpenGL support of the video driver do typically not have an influence on the program setup itself.

just some guesswork:
• run the installtion explicitly by “right click > run as admin” even in the opinion already having admin rights
• ensure that Windows as well as the MS Internet Explorer (used by SU) are fully updated
• check for enough temp space available on your system partition (SSD)
• any special characters in your Windows user profile name?
• do install the MS .NET Framework 4.5 required by SU v2016 by it’s own dedicated installer

I am on windows10 pro. There is no error message as such but I have
attached a screen shot that I get when installing. My video card is AMD
Radeon HD7450 display adapter. I have checked the driver and it is up to

I have run it with the right click and “run as administrator” and got the
same result.
I have no special characters in my user name
The SSD system partition has 33gb free.
I have attached a screen shot of the .net 4.5 installation I did a while
My Internet Explorer version is 11.01.28(3134814). I have it set to
automatically update.
Windows is set to automatically update as well and I am on the windows10
home 64-bit.

Another guess, have you tried running the setup with compatibility modes?

Installed just fine in compatability mode. Thanks very much for your help

Oh that’s great! Congratulations. Enjoy SketchUp! :slight_smile:

Odd, as SU16 is compatible with Win10.

Not with my Windows10 apparently and mine is just a stock version, nothing
fancy with no weird addons.