Sketchup window keeps resizing after any significant pause

Using 2019 pro (19.3.253 64bit) on windows 10 v.1909. with a threadripper 1950X, GTX1080 driver version 442.19, 64gb ram. The performance issue i’m seeing is that any time that Sketchup needs to take time out to “think” (such as saving a file - anything large’ish, say above 30Mb, or processing an intensive task (like rendering a scene) - any time it has to pause to do a significant task, it always jumps / resizes the application window. This becomes a real time waster as i keep having to re-maximise sketchup. anyone else seen this behaviour ? (Layout does the same kind of thing - but no other application on the computer does this)

Standard first question when dealing with oddities, did you use the Right Click method to install Sketchup?
That being, Right Click on the Install.exe and choose Run as Administrator.
If not, do so now and choose repair when given the option.
Being the admin or being signed in as the admin are not the same as Right Click Run as Admin.

1 Like

Thanks for the suggestion - i tried it and it seems to be working better now !

Turns out the problem never really went away - i have still been having the same insane problem with windows jumping around after any time when the computer has to pause to do a long save or pause for any other such computational reason. Turns out though it has nothing to do with Sketchup - it is purely a microsoft issue. If you do some research you will find (on Windows 10) you have to make some changes in the registry to fix incorrect settings for monitor resolution. I havent had a chance to test it fully but I think that is the problem

tested it and it works - so if anyone else has the same problem, you need to edit the registry to make sure you dont have any bogus monitor resolutions settings in there. This is the post text that saved me:
"In the registry under:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

There are folders for each monitor that has been detected.

In mine there are 2 for detected (actual) monitors, both of which have the correct surface sizes set (PrimSurfSize.cx and PrimSurfSize.cy are set to 2560 and 1440 respectively), and there is a third folder which begins NOEDID (which I presume used to be the SIMULATED monitor?).

The X and Y sizes in that folder were wrong (1280 x whatever).

So in the NOEDID folder I changed the primary surface size values to the right dimensions (in decimal), which appears to have fixed it for me.

e.g. in NOEDID set PrimSurfSize.cx to 2560 and PrimSurfSize.cy to 1440 (or whatever your monitor specs are)."

2 Likes