SketchUp will not auto-save


#1

SketchUp will not longer Auto-Save (Auto-Save IS selected at 20 Minute intervals). I get a message every 20 minutes that states that SketchUp has “failed to save.” This problem started two versions ago. No problems with earlier versions of SU. Running MAC OS 10.12 Sierra but problem started on earlier versions.
Thoughts?


#2

Where is it that you’ve asked SketchUp to save files?


#3

Dave,
The option is found in the menu: SketchUp / Preferences / General.


#4

Yes, but…


#5

Ah, Sorry. I misunderstood the question. Using Mac OS 12 - The files are saved in project specific files in Finder / Documents / (Specific Project). Is this what you are asking.


#6

Yes that is what I was asking. Usually when users report this kind of thing, it’s because they are attempting to have the file save to Drp Box or similar and the access is so slow that it times out.


#7

if the folder or file name contains either / or : it will fail to save…

can you also confirm it’s in your HD/Users/<your user name>/Documents folder…

this is mine for example…

john


#8

This is really helpful, John. I do use the backslash on almost all of my project titles. I’ll change the title to remove the backslash to see if that helps. Thanks for your response.


#9

Unfortunately, renaming the files to eliminate all symbols didn’t work - still no autosave. Anyone have any other ideas? I have had just enough “Bug Splats” that I hate to shut off the auto-save feature, especially since it worked up until the last two or three SketchUp versions.


#10

It seems possible there is something we are not getting because we can’t see your Mac. If possible, could you upload your SketchUp preferences file? It is located at

/Users/your_id/Library/Preferences/com.sketchup.SketchUp.2017.plist
where your_id needs to be replaced by (duh) your actual user id.


#11

I’d be glad to do that but I’m embarrassed to say that I don’t know how to upload the preference file. I can say that on the preferences/general screen, I have checked all the boxes. Does that help?


#12

Click the seventh icon from left at the top of the reply edit window (looks like a little bar with an upward arrow). Navigate the finder window that opens to the folder I listed and click the plist file, then OK or choose or whatever (I’m on my phone now and cant see).


#13

Thanks, Steve. I’ll try this tomorrow when I get back to he shop.


#14

Thanks to Dave, John and Steve, I think I cracked the code on this. DaveR got me headed in the right direction. The latest Mac OS system (Sierra) automatically uploads items saved in “documents” to the cloud for access from my other computers. Evidently the process is too slow for SketchUp’s auto-save function and it times out. Once I moved my files to a location where they did not upload to the cloud, the auto-save function started working normally. Thanks, Dave!


#15

Hi, I am having this same problem and tried to work through these instructions to fix it but I’m sad to say that I just don’t follow. I don’t know where the “reply edit window” is so can’t figure out where to change these auto save settings. Can someone please provide more computer dummy friendly instructions??

thanks!!


#16

Hi Mary,

Here is what I learned. The newer versions of IOS (Apple) operating systems automatically saves documents - including Sketch Up files - from your desk top and your documents files to the cloud. This means you won’t loose them if your hard drive crashes of some other disaster. However, the Sketch-up save function times out too quickly to get saved to the cloud and therefore you get the “did not save” message. That wouldn’t be a problem but is is really annoying when you are working on a drawing. The fix: I save a copy of my SU doc in my “Home” file (the little house - you can just drag and drop) and work this version. This file doesn’t save to the cloud. After I have finished working on the file, I move it back to my documents. That solved the problem for me. Good luck.

Jim


#17

Could it be you meant macOS? iOS would be what’s on iPad and iPhone.


#18

Yes. That’s correct.