Sketchup Welcome Screen doesn't work

Hello, Sketchup welcome screen doesn’t work.
When I launch the app I have to right click the SU icon on windows task bar and close so Sektchup main window can appear.
If already in sketchup and try to open the welcome screen from the Menu bar it just freezes.
Already re install a few times and re start the machine loads of times.
Sketchup 2018 on Windows 10

If anybody knows how to fix this please Help!

My guess would be you have more than one monitor and you have change the layout at some stage. It sounds like the welcome screen is opening off screen somewhere.
The usual method of getting an errant dialog on windows is, while focus is on dialog, hit alt with space, them m, then any arrow key and finally without clicking any buttons move the mouse around until the dialog appears.
This may not work with the welcome dialog, if not try the following options.
Try opening SU without any extra monitors. Or when you first open it, go to display settings and move the virtual monitors around until the welcome dialog appears.

Thanks @Box but I dont think thats the case. I can see the window if I press alt+tab and its completely white. it looks freeze.
If I close this windows from taks bar the SU opens normally. But I need that screen to manage my license and template.
PNG

In what environment are you in? Virtual environments are not supported.
Did you install it by rightclicking on the installer file and choose ‘Run as Administrator’?
What happens if you rightclick on the empty welcome screen and choose: ‘View Page Source’ ?

I cannot click on the welcome screen The only place I can see it is on the (alt+tab) window selector.
Its not a virtual environment. and this was working before. just need to change my license and cannot access the window to do it.

unplug one monitor, as @box suggested…

1 Like

This doesn’t make sense, if I close the welcome window from the task bar SU doesn’t open.
Please be specific about all of your issues and how you are doing things.

This solved it. I though that If i turn it off would be enough but unplug it solve the problem. Thank you very much.

1 Like

Who’d a thunk it.

1 Like

Duhh?

1 Like

Thanks for your help. your solution solved it I was follow your instructions wrong.
Fyi when I close welcome screen from task bar SU does open on my computer.

1 Like