Start button off screen - can't click it!


#1

Hi! I upgraded from 2015 to 2017 yesterday. On startup a welcome window opens titled “Welcome to Sketchup”. The window is too big (vertically) for my screen. It is not resizeable, nor can it be expanded to full screen. I can move it by dragging the title bar, but it immediately snaps back into its original position. When I do this, some more of the window that falls off the bottom of the screen can be seen, revealing the top of what I assume is a “continue” or “start using Sketchup” button but I can’t click on it as when I release the mouse button, the window jumps back down again. I can’t close the window either as there is no exit “X”. The only thing I can do is end the program via Task Manager.
Could anyone suggest a solution? Thanks!


#2

Same problem (though not that bad).

You possibly have a system-wide UI scale factor set, and SketchUp 2017 respects that better than previous versions. That means many UI elements appear now at correct size and for some (like the welcome dialog) it becomes obvious that they were designed a bit too big. Also the welcome dialog is not properly keyboard navigatable.

  • change the UI scale factor (e.g. system-wide Display Settings → Scale and Layout)
  • when I close the welcome dialog in the window list (aka taskbar on Windows), it proceeds to SketchUp
  • use keyboard navigation to navigate to the “Start using SketchUp” button.
    Unfortunately keyboard focus is caught in either one section of that dialog. To put focus on the outer section, I click and hold the “Choose template” button, and release the mouse outside that button (to cancel). Now the keyboard arrow up moves focus on the “Start using SketchUp” button and enter triggers it.

Closing SketchUp can also be done with AltF4 (or key on some keyboards).


#3

Excellent! The Scale thing worked! I had a custom scale factor set, apparently, whatever that is. Possibly as a result of switching between screens / projectors with different resolutions?
Thanks very much for your help!


#4

This has been discussed before. currently SketchUp only supports increased screen scales of 125% and 150% See:


#5

That may be “official” support. It all depends on the total screen real estate.

The welcome dialog needs an effective height of 750px, e.g. on a 1920×1080 display users shouldn’t need to set a scale factor and anything over 140% would be problematic, where as on a 4K display a scale factor of 200% still leaves enough space and anything over 280% is problematic.


#6

Esc also works to close the splash window and start SketchUp.


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.