SketchUp weird display (background alternates from normal to lighter color when panning)

bug

#1

Ever since i updated my Nvidia settings, my sketchup has been acting weirdly. Firstly when i open Sketchup (both pro 2015 & 2016) the background seems to be at a lighter color, but as i pan it, it goes back normal and back to lighter color again. I tried reinstalling the software again but to no avail.

On top of that when i drag my mouse to highlight some items the highlight box acted weird (refer image).

Has anyone experienced this before? Hope that there will be a solution to it…


#2

Looks to me as if you have a style selected which has the Sky and maybe Ground turned on. Go to the Edit tab in the Styles window to see.

The Architectural templates use a style that looks like that with a background color and sky turned on.
Screenshot%20-%207_7_2018%20%2C%205_37_18%20AM


#3

Tell more what you did?


#4

I previously tried to play around with the styles as well, but doesn’t seem to be the solution.


#5

How about showing the background settings?

Or are you referring to the white squares sort of thing in your screen shot? If so, does that go away if you turn off Hardware Acceleration in Preferences>OpenGL?


#6

Im not sure what really triggered my SketchUp to act so weirdly but what i did was just update my Nvidia driver as usual, after that this happened. I’ve inserted images of the normal and slightly light background as i pan or zoom in and zoom out.

So far it’s only happening in to this laptop, its using a GTX1050i. My old laptop’s Sketchup is working perfectly.


#7

turning off the hardware acceleration does solve my problem of background, but then the highlight box now acts very laggy…


#8

Turning off Hardware Acceleration makes the CPU do the rendering instead of the GPU. When Hardware Acceleration is enabled, are you sure the Nvidia GPU is being used? Is it possible the integrated Intel GPU is being used, instead? If you are certain the Nvidia GPU is being used, I would roll the drivers back to the previous version that worked.


#9

It is in GPU, tried to go to device manager to roll back, but the rollback button is grayed out…


#10

What does that mean?


#11

Sorry, means it is using my Nvidia Graphics Processor.


#12

Have you tried downloading the previous driver from the Nvidia site and installing it?


#13

Tried… Doesn’t work :frowning:


#14

Try this

  1. Right-click on your desktop and select Nvidia Control Panel.
  2. Click Manage 3D Settings.
  3. In the upper-right corner, click Restore Defaults.


#15

If you are still fighting this, I am finding out that you can have issues going with the latest Nvidia drivers. You need to find one that plays well with SU and stick to it. Go to this PAGE to grab an older driver, try one from Nov. '17. There are a number of drivers to choose from.


#16

Ive tried it before, it doesn’t work as well


#17

Do i have to uninstall the current driver at device manager first? or do i just install straight?


#18

YES remove current driver, do NOT do it in device manager. To remove: Go to apps and features, select the Nvidia Software. there may be several packages. OR run the installer, look real close, there should be a check box for a CLEAN install. OR Go to this PAGE and get the driver removal tool. Follow the directions, it is done in safe mode. This is the best method IMHO. The easy way to get to safe mode is to type" msconfig" in the search box, go to the boot tab and check “safe boot”. Remember to uncheck it when restarting. If using this method select ( in the removal tool) Tell windows not to install a driver. When back in windoze install the driver you downloaded. ?'s PM me, I will be in and out all day.


#19

It’s definitely time to call Nvidia & Windows for tech support… That bug looks really annoying with all the flashing. I hope you’re not prone to epilepsy.


#20

Forest, I have noticed different effects on SU depending on the driver used. The latest and the greatest is not always the best for everyone. A lot of their drivers are optimized for a specific game. I just switched cards and may very well use a driver form last year.