SketchUp Web app not launching in Brave browser; hangs at logo

Three-year webapp user under hobbyist sub.
This is the first time I’ve experienced an issue launching. For at least past 36 hours, when pointing Brave browser to, the wobbling logo comes up and stays. App/navigation never loads; the logo just sits there wobbling. Yesterday, tried MS Edge and that is working, so I’m guessing this may be related to an update/change somewhere between Sketchup web and Brave releases. Anyone else experiencing this or have insights? Thanks!

someone else mentioned the issue this morning

here is my answer. I’d say it’s something in the latest Brave update, since it’s working fine in other browsers.
try to contact them and give your feedback, they might know what changed and how to revert it.


Just FYI: The SketchUp Status page shows no issues with the web app (9th bar graph).

1 Like

Appreciating the responses and info.
I’m also thinking Brave; figured I’d put a shout out before I tried to start chasing that down with them. This is my first time with issues, so appreciate the pointer to the status page, too.

Joining my issue to the prior post cited by ateliernab as same issue and closing this post.

I don’t believe you can close or delete a topic with replies.

1 Like

Would recommend anyone affected by this issue to sound off in the Brave Community thread here. This is most certainly a browser specific issue and giving attention to the thread should help the Brave team assign greater priority to this issue.

1 Like