Sketchup Free won't launch

Hello. Starting this afternoon I found I was unable to launch Sketchup Free in my browser.

It has been unavailable here for about 10 hours.

I use Windows 10 and have been using Sketchup in Chrome.

Is the server “busy”? All I see when trying to launch it is a slowly rotating blue logo.

Have you tried rebooting your computer?? That worked for me!

Do you have more than one browser to try? Does it do it in all of them? Seems to be working.

Same here. After signing in and clicking on the logo just swings back & forth,
This happens in my Brave browser, which strangely previously worked. I have disabled all cookies blocks and turned off all Shields. It is the same issue in Firefox.
The app finally launched in Chrome.

I also tried Brave Browser with no luck, and I know I had used it with Brave previously.

I has to use MS Edge and then it loaded. This was on multiple machines.

So, to close the loop.

For 3 days after the post, Sketchup did not run reliably for me on any machine, on any browser.

After those 3 days, Sketchup ran reliably in Edge and Chrome, but will no longer run in Brave, which I know it had previously.

yeah, a week or two ago, it apparently stopped working in Brave, they updated something.

SU’s team made contact, technically Brave has never supported sketchup, but it’s based on chromium, and chromium does (it’s even included in SU) so…
so now it’s in Brave’s devs hands.