SketchUp Free (browser based) won't launch

mac

#1

Whenever I try to launch SketchUp Free by clicking “start modeling,” it just reloads the web page and doesn’t launch. I have tried this on Firefox, Chrome, and Safari, and all of those web browsers are up to date and I just updated my computer to Mac OS X 10.11.6
Does anyone know of any solutions or work arounds? It was just working yesterday.


#2

A student (I’m a teacher using this for a 3D printing unit) just discovered that you can launch it by scrolling to the bottom of the SketchUp Free page, clicking “Learn about SketchUp Free” then clicking the first hyperlinked “SketchUp Free” (in red). So it appears that the problem is with the “start modeling” button - any suggestions on how to bring this to SketchUp’s attention?


#3

@TheOnlyAaron


#4

You can also just go to this URL: https://app.sketchup.com/app


#5

I have tried to recreate this on Chrome & Safari, but the link appears to be working for me. Are you trying to click through on this page? https://www.sketchup.com/products/sketchup-free


#6

I don’t use SketchUp Free but when I tried to replicate this issue this morning I ran into the same problem.


#7

Thank you- that works! I was typing in app.sketchup.com without the/app. That must have been part of the issue


#8

Yes - now it appears to be working. We tried from 8am - 10:30 am AKST and kept running into the “start modeling” button not working.


#9

I seem to be having the same problem as many people; the SketchUp Free launch only gives me the throbbing logo, but never launches the app. I’m using the latest version of Chrome on a Windows 10 64-bit gaming laptop with 16G of RAM and an NVIDIA GeForce 660M graphics card. I’ve seen suggestions that it’s lag, but I’ve left the site open for almost 2 hours now with no change.

Even stranger is that if I launch it with Internet Explorer, it runs fine, even though I get the “Whoa there, cowboy” message at the start. (Very nice touch, by the way. :slight_smile: Nice to see you guys have a sense of humor.)


#10

I am suffering the same problem in Chrome (latest) on Win 10. Edge works with the warning but I ony get the throbbing logo in chrome.


#11

I’m having the same problem. I am using Windows 10 with Chrome. I go to the main Sketchup App page and all I get is a throbbing Sketchup logo. I can load sketchup in Firefox, but not Chrome. I tried deleting Chrome Cookies and Cache for Sketchup, but it didn’t resolve the issue. I hope someone from Sketchup can resolve this issue.


#12

Same problem here! Windows 10. Chrome. AMD Radeon R7 Graphics


#13

@jbacus Any ideas on things to try here?


#14

Do you not see any kind of error message at all? Just the SketchUp logo and nothing else?


#15

If the problem isn’t a transient one, in other words a problem which goes away if you try again later, then we should check the usual suspects: your OS, Browser, GPU and driver.

Which version of Chrome are you running? Google updates the parts of the application we depend on the most (WebAssembly and WebGL implementations) pretty frequently, sometimes with significant impact.

I use a Mac, not Windows, but I’m running Chrome version 66.0.3359.117 (Official Build) (64-bit)

Which version are you using?

john
.


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.