Sketchup Web stuck on logo, won't launch

Hello,
Sketchup web is stuck on the sketchup logo, performing its loading animation. It wont prgress past this initial screen.
It worked last month when I last launched it.
Please let me know what steps I can take to troubleshoot/if the service is down.

Try clearing your browser caches and see if that helps. It has for others who have reported this.

Thanks for the speedy response,
Hasn’t fixed the issue - I even tried alternative browsers!

Hmmmm… Where are you located on the planet? I just timed opening it here in Chrome and it took about 5 seconds.

UK :sunglasses:

Maybe the server is getting some maintenance?

@colin?

I don’t know of any server work, it’s a Federal Holiday for us today.

It seems ok for me, even if I vpn to be in the UK.

We had a case a few days ago where someone was getting a WebGL error. To try and isolate whether it was a SketchUp or a WebGL error, I suggested trying this page:

https://get.webgl.org/

I don’t know if that actually helped, but the next reply we got was to say that after clearing four weeks of web data that the error went away.

It’s very likely you’re not having a WebGL problem, but that site would be a quick way to tell.

Can confirm my browser shows the spinning cube without any problems, I’m using chrome so WebGl compatibility isn’t an issue.