SketchUp Web/Free is down?

Today (31-3-2020) I try to login for now 7 hours, but the only thing I get is the Sketchup logo beating like a heartbeat. Is the system down or overloaded?

I just tried from the UK, it took about 2 minutes (logo heart beating) but then it loaded just fine.

Thanks. But here in Holland it seems not to work. Who to contact within SketchUp?

The team will probably check it out when they see your problem posted here.

I moved your post to the right category so the right people will see it.

Let’s hope so. Now is the (Quarantine) time to work with this software.

Try clearing your cache or try another browser.

I tried. Stays the same.

The site is working, and the clearing cache is the best hope. But it’s not normal browser cache, it’s WebGL cache that needs to be cleared.

To see if that will have some hope, try another browser. See this article for clearing the right cache:

Hi there. I now switched to using Firefox in stead of Google Chrome. Now it works fine.
I tried to clear my WebGL cache, but not sure ow to do it. Q: What does it exactly clear? My browsing history, passwords, settings, ???

The article I linked to goes through that I think. You’re clearing cached data, not cookies or passwords. With Chrome you can choose how far back in time to clear cache, and you could try clearing as little as possible, to see if that is enough to fix the SketchUp app.

2 Likes