Sketchup for web will not load - stuck on rotating logo

I’ve tried Chrome, Edge, web apps, everything I can think of.
I’ve cleared cookies and cache.
Every now and then it will log in, and function normally, but if I close it out it takes a lucky break to get back in.

I’ve tried rebooting, relogging in. Baffling.

Possibly ad blockers or firewall preventing your access?

1 Like

Very odd. I just pinged the server to make sure all is well and everything came back looking good. My best guess without more information would be the same as RLGL. Are you running any apps or add ons that restrict the site itself? Maybe a VPN or pop up blocker? Perhaps a firewall setting got adjusted by mistake?

I am working on a state (Virginia) agency computer. I had been trying to access with no VPN active.

When I accessed WITH VPN active, it opened right up! That explains the variability in when it would open or not open.

Thanks for the reply justen913. My guess at this point would be a firewall setting got adjusted but without more information I can’t say for sure. If you have an IT department, I would recommend checking in with them and seeing if any changes were made on their end in the last few days.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.