I can't get into Sketchup - Logo keeps wobbling

I’ve got Sketchup for Web as a Brave Browser app. It has worked flawlessly up until yesterday. When I started up the (Brave Browser) Sketchup App on my MacBook Pro (Catalina), the logo comes up and wobbles from side to side like it always does when loading, but nothing happens. All I see is the logo. I’ve tried deleting cookies and browsing data, logged in again, but the result is the same. It won’t load.

Update: I have tried running the Sketchup App in Chrome, and it is running just fine! The problem has occurred in my primary browser; Brave Browser. Since I practically never use Chrome, I would be really grateful on any tip on how to get Sketchup to run normally in Brave.

Thanks!

Been having the same problem for the last week. Have used the free version for a few years without issue on Brave web site. Saw your post and tried it on Chrome and it works fine.
Would be good if someone could find a reason for this and a solution.

if changing the browser fixes it, it’s likely an update in your browser.

I’m using firefox and opera GX (that one mostly for streaming services)
a couple of weeks ago, opera GX started misbehaving, and videos became choppy. a few days later, an update came and fixed it.
it wasn’t the fault of any of the video services I was checking, they did something to the material acceleration.

Sketchup web hasn’t pushed an update recently, so they didn’t change anything (as far as I know).
therefore my best guess is that your browser updated and changed something.

you should give that feedback to Brave’s devs, if they don’t know it’s bugging, then there is no bug to fix. and they can check what got updated in the last weeks that can cause this.

1 Like

Thank you for the reply.
I will let Brave know about it. At least I can still access the program through Chrome.
Regards

2 Likes

Having the same issue with Brave on Win10. Had Edge handy and it worked there, so def looks like Brave.
Opened my own post earlier, but will close that and join forces.