Sketchup VR (Quest Meta) EULA

I am trying to use the Sketchup VR Viewer on a Quest Meta for the first time.

When I launch the app, I get a pop up “One more thing…” and a request to accept the EULA. I have not been able to click the ‘Accept’ button on the Eula popup. Clicking the buttons does nothing.

Am I missing something? How do I accept that Eula popup…?

I have a Free account for evaluation, thanks.

I have commented on the EULA checkbox internally. For me it was sort of a parallax issue, where clicking on the box wouldn’t work, but slightly higher and it would.

Do you know how to make and share screen recording for the Quest? At the very least a picture taken at the time would help make sure that you’re at the same stage I was when I had problems.

Sure. Video here: b16da31e06523d07b69e70242ccceb61.mp4 - Google Drive

Video of both attempting to click the buttons, and also attempting to click the checkbox.

Note that it appears the first part of the video there actually isn’t a pointer on the screen. But even when there is a pointer, it doesn’t seem to work.

Thanks. My Quest Pro already has the app, but my Quest 2 doesn’t (I don’t think). I will charge the Quest 2 and see what I get.

Hi @chicagoandy

Thanks you for reporting this.
Me and the team will have a look and see if we can fix this in the next release.
Apologies for the inconvenience.


Given that it seems the app is quite broken and new users can’t sign up, you might want to look at something quicker…

I did compare my case with yours. For me, the wand ends with a circle all of the time, and it does manage to operate the buttons and checkbox ok. In your video you only have the circles later on, which might suggest the hot spot for the press is happening way behind the panel with the buttons on it.

When the circles do appear, do the buttons and checkbox then work? The two buttons take you to the actual agreements that are online, and those links do have their own issue, which I will tell Aris about.

In the meantime, once you have the circles at the end of the wand beam, it should allow you to check the box to agree to the terms. The angle you need to be at is misleading, think of the beam continuing at its current direction, and then having to hit the button. If the circle is visually on top of the checkbox the beam itself might pass up and left of the box, and so won’t operate it.

Here is my beam at the time that it was at the right place to check that box.

Hi @chicagoandy, and @colin thank you for the detailed comparison.

The team is already working on some alternative designs to make this more intuitive and easy to get through.

Having said that, and upon closer look at the video you shared earlier @chicagoandy I noticed that at the start of the recording SketchUp Viewer is not “active”. Note that after you initiated the recording, rather than clicking on the “Resume” button you minimize the application card which keeps SketchUp Viewer visible in the background but it is not active:

That means that for most of the recording you are trying to click on the SketchUp Viewer panel but the whole app is in “pause” mode (notice the Quest toolbar at the bottom):

The Quest toolbar goes away at approximately 00:40 in the video where your ray’s endpoint becomes active again (it turns into a dashed line featuring the small circle at its end). What is tricky to understand in the video is whether you are clicking on the trigger button (index finger button) when pointing over the “I agree” checkbox. If you clicked using the trigger button, the ray should turn from dashed line to a continuous line which never happens in the recording.
Can you please confirm that you were trying to click that checkbox using the trigger button (see reference below):

Thank you,

It being in the background explains the missing circle I mentioned.

It’s possible that chicagoandy switched out of the app to set the screen recording going, and never switched back into the app. When I did my screen recording I set it going by holding the menu button down for a few seconds, and pressing the trigger. That sets the video recording without having to switch out of the current app.

Hi all,

Thanks. I was able to accept the EULA by aiming below the box. Yes, it was likely I didn’t have the app active each time I tried this. I also had this same problem even before recording the session - navigating to the actual EULA (clicking the button to read it) also made the app inactive.

Anyways - thanks for the help.