Sketchup VR Viewer is not detecting my Quest 2 headset

My Oculus Windows app is detecting my Quest 2 headset, so the cable and headset seem to be fine. But the Sketchup VR Viewer says “no VR device detected”. Are there any viewer/account settings that I could change? Anything else I can do? Do I need to buy a different VR headset? Who has had this issue and were you able to solve it?

Are you keeping the Oculus app open when trying SketchUp VR Viewer?

Not part of why it’s not working for you, but Air Link is worth checking out. Saves having to have a cable between the Quest 2 and your PC.

AirLink works with the Oculus mobile app, but pretty sure you need the cable to connect with Oculus on Windows PC–although I now do remember they offered me a option to set it up without the cable. Do I need to disconnect the Quest 2 from the Oculus app, so the Sketchup VR Viewer can see the headset? Does the Sketchup VR Viewer rely on the connection from the Oculus App to the Quest 2 headset or does it create its own connection? There is so little info out there by Sketchup, so hopefully this thread can fill this in a bit.

1 Like

I seem to remember that one needs to install SteamVR on the PC.

Hi @konstcommercial,

Make sure you open the Oculus Desktop App, and in Settings Oculus is set as the 'Active OpenXR Runtime device.

Then try to run the SketchUp VR application again
Let me know if that works for you.


I did set up Oculus as OpenXR Runtime. There was a pointer to it during the install, so I did that. So, this is unfortunately not the issue. Are you successfully using Quest 2 headset with Sketchup VR Viewer on Windows 11? Just would be helpful to know if this working for someone and then see what they did. Or maybe it is just a pipedream…

Hi @konstcommercial can you explain what you mean by saying that the Oculus Windows app is detecting the Quest 2 headset?

As Colin explained with the link he shared you need to connect the Quest 2 via Oculus link (cable) or AirLink (via Wifi) and get into the ‘Link’ mode before you can run any PCVR applications.

If you manage to connect successfully you will see a screen like this inside your Quest 2:

After you see this screen you can then run the SketchUp Viewer .exe file from your Windows machine, and SketchUp Viewer will launch on Quest 2.

Hope that helps.


Aris showed a screen with the Quest 2 end of things, for Air Link. In the PC application you need to go into the Beta tab, that is in another screenshot from Aris, and that’s where you turn on Air Link.

As long as the PC and headset are on the same WiFi network, you shouldn’t need to connect the cable to set up Air Link.

Hi @Aristodimos, are you Greek? Thanks for the screenshots. A picture is worth a thousand words. I said my Oculus Windows app was connected through the able since I installed it that way and based on the devices tab is said “active”. I did not know how how to go to Settings and the environment like your screenshot, but I got there now with the cable on (it offered me the option to AirLink, but then it did not find my machine even though it is on the same WiFi).

So, how do I now get the Sketchup VR Viewer into the Apps window, so I can launch it? It is installed on my Windows PC, and before I tried to launch it from there…

I found the viewer by searching and was able to get into the app with the cable. Very nice. It did not load my model though–it said “unable to load–try saving it to an earlier version”. What are the limitations of what models can be viewed in VR?

@MikeWayzovski I have it up and running now without Steam

Hi @konstcommercial,

Yes, I am Greek!

I don’t know the reasons why AirLink might not work but you should make sure that:

  • (As you already confirmed) both Quest 2 and your machine are on the same wifi network.
  • It is recommended that your windows machine is actually connected to the modem via an ethernet cable (but can in fact work without this )
  • the Oculus Quest application is open on your windows machine when you try to launch air link (or oculus link for that matter)

Once you mange to get in the Oculus Link home (the second screenshot you shared) using AirLink or the Oculus Link Cable, you are good to go. All you have to do is simply double-click on the SketchUp Viewer .exe application on your windows machine (you will need to momentarily remove your headset to do that…) and it should begin running on your Quest 2. Once you put the headset back the application will be running.

If you have not yet downloaded the SketchUp Viewer application follow these steps:

  1. Make sure you have a Trimble Account and a valid SketchUp Pro or Studio subscription.
  2. Visit yourMy Apps”.
  3. Go to 'My Products, Click on View Included Applications and Download ‘SketchUp Viewer for Oculus/Vive’

Note that if this is the first time you are opening the application you will be asked to Sign In which will launch a browser window on your windows machine. SO you will have to remove the headset again momentarily.

Hope that helps. If this is getting too confusing let me know and we could arrange a call.


Aris, yes I did download the Sketchup VR Viewer from that page. I figured it out on my own, but good you are posting it here for people. Launching the EXE from the Windows desktop, however, still shows “no VR device detected”, so the solution is to install the viewer from inside the Oculus Windows app, and then it shows up on the headset and it works fine–except that my model won’t load. I will ping you directly to see how I can save it in an older version or what I can do to make it work…

yep, silently following this and yes it is painfully confusing…

about time Sketchup took VR/AR seriously…

A Sketchup forum VR category might be a good start…

the millions of SU users and 1000’s of them with VR should not have to rely on “making a call”

and that is no reflection on your dedication to support Aris, which is certainly appreciated

Some of that issue is from using a quest 2 which has a few extra hoops to jump through - they are notoriously finnicky to use with desktop applications.

Using mine for games and other applications such as enscape and Hitman 3 can be just as painful with headsets not being found.
Software that supports APIs that both Oculus and SteamVR have proven to be the most problematic for me - I usually have to totally kill SteamVR from running in those cases, otherwise that gets detected before Oculus can do what it needs to do.

Firstly let me tell you that I really appreciate everyone’s feedback in this thread.

@gsharp I do agree with you that we need to take AR/VR more seriously and that is exactly what I was hired to do. I am the dedicated Product Manager for our AR/VR solutions, and while I do not have anything to show for right now, let me tell you that the team is working hard to deliver solutions that will delight SketchUp customers (and hopefully their customers as well :slight_smile: )

There are already two subcategories in the Forum under the general SketchUp Viewer category for VR, and Mixed Reality. I am watching them closely, so feel free to use them!

@Elmtec-Adam it’s definitely a struggle but our goal is to support the platforms that our users enjoy using the most.

1 Like

Oh definately, the more people that can use it the better!
It’s just an unfortunate thing that the Oculus and Steam installers that all headsets use like to fight with each other - obviously this is not a SketchUp problem!


I also found the solution to “no VR device detected”. You have to have the Oculus Windows app running first and under general settings, you have to turn on “unknown sources”. Then you can launch the Sketchup VR Viewer EXE from the Windows desktop and see it on the desktop as well as in the Quest 2 headset. If you don’t do that, you can still open the app from inside the Quest 2 interface under library and apps after you install the viewer via the Oculus Windows app.

I also got AirLink to work eventually–it was just not finding my PC at first. They were both on the same network, but the permissions were such that they could not find each other. Once I changed the permissions, the headset found the PC and AirLink worked with my PC just like with my Android. Not sure why this was not an issue with Android, but just wanted to let everyone knows that Airlink can work with the PC and you don’t have to buy the cable.

1 Like

Airlink is great if you’ve got a good setup.
I play my games wirelessly with it, it’s awesome being cable-less