Oculus Quest 2 with Sketchup Viewer - No VR Device Detected!

"Please connect a VR Device" It’s already connected!

My Oculus 2 is incredibly frustrating. I have used it with sketchup a few times, but it’s ALWAYS an unbelievable hassle to get the thing recognized and turned on. Can’t use it with clients because it’s undependablre.

My Quest is installed, plugged in and turned on. The apps are downloaded and drivers are current.

When I launch Sketchup View I get a brown screen with a tiny letterbox that reads “No VR Device Detected - Please connect a VR Device”.

The oculus is on, and I can get to my home space, but the VR app is not to be found in there and I can’t find any of my files.

I’m running a brand new Dell with NVIDIA Studio RTX card. I have a top quality cable with the necessary fiber optics and charging capacity etc.

I feel your pain.

First a strange finding. I recently attempted to download and use SketchUp Viewer for WMR/HoloLens. That didn’t work. I downloaded and installed the SketchUp Viewer for Oculus/Vive. I don’t recall whether I installed SteamVR at that time or if I did so when I was setting up an environment for something else. But, in any case I didn’t set an Oculus up at that time. But SketchUp Viewer for Oculus/Vive works with WMR & WMR headsets. ?Extrano, no?

If I run WMR Portal, then launch SketchUp Viewer for Oculus/Vive, I sometimes get the brown skybox with the “No VR Device Detected…” message. I’m presuming you’re seeing the a SteamVR error as well.

The WMR Portal often fails to detect the WMR Headset. 1) Unplug external monitors. 2) Restart computer. 3) Check that the cord connection on headset is not plugged with magic smoke (for whatever reason, that connection is a weak link). 4) Start the SketchUp Viewer for Oculus/Vive first without starting SteamVR (or WMR Portal in my case).

From your message it seems you are Running SteamVR (or whichever “home space”) first. Try launching SketchUp Viewer for Oculus/Vive first.

One thing to look into is that the current Oculus software has a beta option to turn on Air Link. I’ve had better luck with that than with a USB-C cable. Read about it here: