Sketchup Viewer for VR start up

Hello,

I am using SketchUp Pro 2019 and would like to try export my model for SketchUp viewer for VR.
I have Oculus Rift for my VR device.

After installing and opening SketchUp viewer for VR, I only see the horizon picture and no Home Screen appears.
I am connecting my VR with cable.

I cannot find any menu, so I open up task manager and force shut down to do any other work on PC.

I tried opening my SketchUp and export through Extension (SketchUp Viewer AR/XR), however,
SketchUp had frozen and nothing happened.

Could you please tell me any possible reasons for these errors?

Thank you very much in advance.

1 Like

I think that you may have only followed the article about using using the AR/XR extension, missed several of the steps in the SketchUp Viewer for VR article:

https://help.sketchup.com/en/sketchup-viewer/sketchup-viewer-vr

That article also links to the Oculus articles on downloading and setting up that software as well. Here is the Oculus setup article:

https://support.oculus.com/525406631321134/#setup

Once you have downloaded the Oculus software and used it to connect to your headset, the SketchUp Viewer application can let you open any model and view it on your headset.

The right viewer application can be downloaded from your account management page. The way you get to it seems different now, I will have someone look at that article to see what needs to be changed.

To get the right viewer application, go to this page:

https://ecom-prd.trimblepaas.com/ecom/portal#/subscription

Choose My Products, and in the entry for SketchUp Pro, click on View Included Applications. That will show all of the things that are included in the SketchUp Pro subscription. One of the items is for SketchUp Viewer for Oculus and Vive. Click on the Download link to get the viewer.

So, once you have the right viewer application, and the Oculus software recognizing your headset, you should be able to sign into your account on the headset, and view any of the models you have uploaded.

I’m not sure about the use of the extension, I haven’t needed that so far, I have been getting models from Trimble Connect or 3D Warehouse.

1 Like

Hi Colin, thank you so much for your kind reply.

I already installed the viewer from My Products.
(I used AR/XR extension since the viewer didn’t response well.)

I am using the Oculus for another application and there is no problem.
Actually, I was able to install SketchUp viewer for VR for Oculus in Oculus App store.

Installation was done successfully, but I could only see the horizon and nothing else.

It seems there is no problem on SketchUp but Oculus.

I will try updating and looking up settings for Oculus.

Thank you very much for your help!

1 Like

I had forgotten about the app in the store, even though I have installed that myself as well!

I didn’t have any problem with the Oculus store app, but it’s a few weeks since I last tested it. I test with Oculus Quest, and using my work Mac running Bootcamp. Both need a recharge, I’ll set that going now.

1 Like

My Oculus software needed an update, so did Quest, but after that the app worked and I was able to sign in and view a model.

Hi Colin,

I checked my Oculus update and I did it, but no result changed.
(I even repaired the Oculus software.)

I cannot see the sign-in window but only horizon…

Actually I tried installing SketchUp viewer into another PC in my office.
The PC does not have USB 3.0, so there are no VR device connected.
Once I open the SketchUp viewer, it says
“There are no device found. Please connect a VR device”
and there are icon that says “Start without VR device”
I clicked the icon and tried without VR, and I was able to see SketchUp viewer menu.

So, I tried unconnecting Oculus for the PC which has USB 3.0
and opened SketchUp viewer, but nothing happend. The same error occurred.

If you and anyone else have any idea, please let me know!

Thank you!

The cable needs to be of ‘High’ quality. Did you buy one from Oculus?

Hi Mike,
Thank you for your reply.
I am not sure about the spec of the cable.
It should have came with the headset.
I am able to use my Oculus for another app, so I think there is no problem with the cable…

No problems here with the VR viewer on the Oculus Quest. I bought a cable from Unbound VR (USB A-C), but you can also use the cable from your Oculus Quest charger.

In my tests I find that the charger cable doesn’t work. I got Quest early on though, they may have improved the included cable since then.