Sketchup very unstable on my Laptop


#1

Hello
I’ve installed Sketchup on my Laptop (New HP Pavillon Windows 10)
And it is very very unstable, it crashes regularly after a bunch of simple manipulation on very simple drawing
And I didn’t fin a common to get it Scenario yet
Is there known weakness or environment incompatibilities ?


#2

main reasons for program crash:

1.) incompatible or faulty plugins installed
2.) incompatible graphics adapter in use

evaluation:
1.) disable all plugins (“Window > Preferences > Extensions…” or by moving plugins away from SU plugins folder or by disabling all plugins per Ruby console)
2.) disable display output acceleration by graphics adapter (“Window > Preferences > OpenGL > Use Hardware Acceleration”)

fixing:
1.) use recent plugins released for your SU version only
2.) update the driver if avail and if this doesn’t help use a dedicated graphics adapter (nVidia GeForce GT(X) rec.)


#3

Thank You sketch3d_de

You are right
1- I’ve first disabled the pluging, restart and do some work : it crashed again
2- Then I’ve disabled the hardware accelerator, and now it is much better ;
a) Sketchup start more faster
b) no crash since till now

I have an HP Pavillon whith 2 Graphics adapter
AMD Radeon R7 M260
AMD Radeon R5 Graphic


#4

Disabling hardware acceleration means your CPU is doing all the work. Dig further to identify the exact problem. Some of the recent (within the past year) AMD drivers haven’t been fully OpenGL compliant, but it’s too early to point fingers at that.

With laptops, by default integrated graphic chips are used to conserve power. Go to graphics control panel. Under 3D settings choose SU and select your best graphics card to be used with SU. Does SU work better with hardware acceleration re-enabled?

If not, try updating graphic drivers. Restart your computer. Try SU with hardware acceleration enabled. Better? If not, options include rolling back driver, living without hardware acceleration in SU and trying an older driver.

Somewhere during this process, update your OS for good measure (SU uses stuff bundled with the OS browser.)


#5

Thank you catamountain

Unfortunately I already spend a lot of time trying to learn SU and getting something out of it
And I don’t have to many time to spent to play with my machine configuration to get SU working without crash !

Anyway I will try
What do you mean by
Go to graphics control panel. ?
I don’t know about a "Graphic Control Panel"
Never ear about


#6

The control panel for your AMD cards. It was called Catalyst for AMD. The simplest way to get to it was r-click on empty desktop space. It could be listed in the context menu.

If everything is working OK without hardware acceleration, there’s no big rush to ‘fix’ things. But as your projects get larger - and SU begins to bog down - it then would be time to get your graphic drive to do more of the computational work.


#7

Thank you catamountain
I get it !


#8

you may also want to run the ‘HP Support Assitant’ to check for recent driver updates of your system.


#9

Good Point !
I already did it yesterday

And a few drivers were updated
I will check again with Sketchup


#10

About a week ago I finally upgraded my system from Vista to 10 and thus changed Sketchup version from 8 to 2017. While I am overall quite happy with the progress the program has made, and have grown rather fond of some of the added functionality, I appear to have the same issue with random crashes.

I am using a very complex model containing loads of components (at least a couple of hundred of them) and the sketchup keeps hanging occasionally, just going completely dead, sometimes it recovers after a minute or two, sometimes it just crashes, creating a bug splat screen.

Just now it crashed while moving a simple surface. It crashed and rather than move my surface (as a component) 30m on green, it moved it somewhere across the model and then subsequently crashed. To be fair, I think I could positively link the crashes to either “move” or “move a copy”. (on one of the previous crashes, I had a large surface - about 100m by 100m by 0.2m , which I offset by 0.1m and then moved away the central bit after the offset. When I pushed down on the edge I obtained hby offsetting the surface, I got a message that sketchup realized that my model was damaged and I could only repair it, so I did. Which resulted into random lines reuniting the vertexes of my offset edge to the ones of the already moved away surface. Thereafter, Sketchup crashed.

Considering this behaviour, I am saving my files after almost every operation, just to be safe.

Another thing I have noticed: ctrl+z does not work consistently. Sometimes I have to keep it pressed for several seconds and nothing happens, and then several undo’s are performed which I have to redo with ctrl+y in order to get to where I was. The thing is that sometimes it works just fine, on the occasions where it is not working, it almost seems like there is a bottleneck, sketchup doesn’t know what to do so it just sits there doning nothing.

To be fair I am also running quite a number of plugins - namely the ones I have used since sketchup 8 and that have never given me any hassle.

And nope, I’m not running on a laptop :slight_smile:

As to this particular thread, I have just disabled output acceleration so I’ll have to see whether or not that helps. If so, I shall post here.


#11

The symptoms you quote might indicate trouble with using old versions of plugins. There have been a couple of updates in the Sketchup Ruby plugin engine since version 8, and it is strongly recommended that you only install plugins that have been updated to work with the newest version. Try first disabling all plugins.

What does that mean? Sketchup version 2017 requires a graphics card that supports OpenGL hardware acceleration, so there is no more even an option in the Preferences to turn it off.

Anssi


#12

Hey there :slight_smile:

Ok, I admit, I was a bit ambiguous. I didn’t mean to say that I copied over plugins from sketchup 8, I meant to say that I have downloaded the new versions of the plugins I am used to: weld, soap bubble, artisan, round corner. Addidiotnall I added some new ones that I might actually disable because I havan’t used them yet in a week’s time of working 12 to 14 hours a day and basically drawing a house from scratch; so I likely will never use some of the new ones.

And ok fair enough, I didn’t disable opengl, I merely unticked the use fast feedback box.

Still I just went busy around the house waiting for my computer to recover without a reboot after yet another sketchup crash. Not sure if it was sketchup this time though, as, at the time, I was fiddling with the material editor in the new vray beta I’ve installed three days ago.

Nonetheless it’s very strange.

I only upgraded my windows because in school I will have to go through autocad and inventor and revit later on and those need windows 10. Upgrading sketchup was a blessing in a way as the new one works much better than sketchup 8, I suppose it is better at making good use of my new computer. Still, I do miss the stability of the old sketchup. It might have needed a while to do what I wanted it to do in models with a couple of hundred of components but at least it did’t crash. In 5 years of sketchup 8 I think I have only experienced about as many crashes as I have with sketchup 2017 in a week. So I don’t know, one the one hand there’s performance which 2017 delivers, on the other there’s stability which, as far as I can tell, it does not deliver.

sigh


#13

At work I use AutoCad 2017 and Revit 2017 with Windows 7 without any problems. The 2018 editions have not yet come out, I don’t know what changes they will bring. With the large corporate user base I would guess that Autodesk will support Windows 7 and 8 for as long as Microsoft does.

I would say that running beta plugins poses the same risk as running outdated ones.

As said, ensure that your display driver is up to date. If your computer has both an Intel display chip and a Nvidia card, make sure that SketchUp is set to use the Nvidia one. Try disabling all plugins, and, if SketchUp stops crashing, try bringing them back in one by one, for instance.

Anssi