Sketchup Suddenly Creates a bugsplat when I try to open it

crash
startup
bugsplat

#1

I have been trying for several days now to open and work with Sketchup Pro 2015. It was fine last time I opened it and now it creats a bugsplat before it gets up.
Things I have already done:
Updated my AMD Radeon HD 7770 vid card
Updated windows
Uninstalled and reinstalled SketchUp
Rolled back my computer to a date before I installed

Nothing is working and Sketchup is a really big part of my job
Please Help


#2

I assume you mean you have updated the GC drivers ?

Did you install SketchUp “as an administrator” ? - using that context-menu option [NOT just as yourself - even if you do have admin-rights the results will not be the same]

Did you set the SketchUp.exe file to “always run as administrator” ? - using context-menu Properties > Compatibility options.

What is your Windows OS ?
If it’s recently upgraded to Win10, then did you try setting the SketchUp.exe to run as if it were opening under Win8 ? - again using context-menu Properties > Compatibility options.


#3

Hi Shawn-

Thanks for putting your contact info on the bug reports, I see that SketchUp has been having some significant issues on your machine recently. I’m glad you posted here.

Here is the crash stack from your crash reports:
KERNELBASE!RaiseException
mx_r20

Do you have the Maxwell rendering plugin set up for SketchUp? I believe that’s what “mx_r20” comes from. Try disabling that plugin and see if that stops the crashing.

Thanks,
Marc


#4

Thank you for the help. I was having a panic. I am still fighting with my SketchUp but I feel like I have help now.
I do have a question.
How do I disable the Maxwell Plugin if I cant get sketchup open?


#5

Remove - or just rename - Maxwell’s RB file in SketchUp’s Plugin directory.


#6

yeah…not on my puter any more…and I am still getting bug splat…sheesh.


#7

Where was Maxwell installed ?
In the User’s AddData…Roaming…Plugins folder or the similat Plugins folder in ProgramData path ?
How did you ‘uninstall’ it ?
If there is a related rb [or rbs] file to find, then it will auto-load as SketchUp [tries] to start…
Try renaming the “Plugins” folders in both locations as say “PluginsX”.
SketchUp will recreate the User folder as it loads and copy in the su_ shipped Extensions but you should then have a Plugin free SketchUp to open and tweak…


#8

It’s still the same crash, so keep working on it. I don’t have a copy of Maxwell to say exactly where it’s installed, but my SketchUp plugins are installed in C:/Users/mdurant/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins. If you rename that folder as TIG suggests, it should take SketchUp back to the default state as far as plugins go.

Thanks,
Marc


#9

If Maxwell [or other files are installed] in the C:/ProgramData/…/Plugins folder [I don’t have Maxwell either, but I suspect this is a path used by it’s custom-installer], then you need to disable [rename] that folder too, so as to stop it auto-loading any of its Ruby files as SketchUp starts…


#10

Well…
Before I knew about the hitch with Maxwell I rolled back my puter to June. Before I had SketchUp 2015 and I started over.
Still got the Splat.
I got on this forum and Ya’ll suggested the Maxwell Plugin…I did a search and did find Maxwell Textures still on my system. I deleted those files.
Reinstall Sketchup 2015…Bug Splat.
So the I found the Plugin folder…renamed it as suggested…reinstall Sketchup…Bug Splat…
So Front Line Support sent an article about Ruby Files…I will be searching for those tonight…and If that doesn’t work…maybe I’ll just back up my docs and reformat!!! Acck!!


#11

Whoo hoo…I finally got it.
FYI it was a Maxwell file hidden so I had too look very hard.
But I have a working version on SketchUp again.
Now I guess I have to work
Thank you all!!!


#12

Great!

For future reference, where was the Maxwell file hidden?

thanks,
Marc


#13

While I don’t know where the renderer was hidden, this is one way of unhiding hidden folders in Windows (one should be able to access folder organization from any folder, not just in a ‘Library’ as shown.)


#14

ThomThom has an extension to check if a plugin is in the Windows VirtualStore.


#15

Hi Marc,

I am having the same issues. As soon as I open Sketchup it opens the Bugsplat page. I have the pro 16 version. Tried reinstalling. Submitted report and submitted a maintenance request. No replies. I use this software for work purposes.

Style Builder won’t open either. “program needs to close”

Layout opens fine.

Thanks,

Ted


#16

Trimble will have more info from the BugSplats, but while waiting for Marc to respond, here are a couple of things you could check (frequent causes of crash-on-open bugs):

  • is there an update for the driver for your graphics card?
  • have you uninstalled all extensions/plugins and tried then? (you can temporarily rename the plugins folder to kill all extensions/plugins).

#17

What OS and SketchUp version are you running?

I don’t see any crash reports in our SketchUp 2016 database with your username on them. What name are you putting on the crash reports?

Thanks,
Marc


#18

Thanks for getting back to me. I am running Sketchup pro 2016 64x

Windows 7

AMD Radeon HD 8790M

I use my name on the reports. Ted Noble and my e-mail

Thanks

Ted


#19

The crash report number is 16837. I just resubmitted it now.


#20

Crashing on atig6pxx. One solution for people has been to run the 32 bit version, or see if there’s an upgrade for your driver.