Mystery: BugSplat after choosing template

Hello good folk.

This problem has been bothering me for months, and months, and months. Any and all help would be appreciated.

When using SketchUp Make, program opens fine. When selecting any template and clicking ‘Start Using SketchUp’, a bug splat appears.

Have tried reinstalling, have updated Java and Graphics card drivers (NVIDIA GeForce GTX 680M). Have also tried deleting temp and SketchUp files in AppData>Local and Roaming. Running Windows 7 Ultimate, Service Pack 1, 64-bit.

Interestingly, downloaded another free CAD software last night that runs on Java, and that crashed upon opening too. Not sure if they’re connected. It was ‘Sweet Home 3D’.

I can use SketchUp viewer just fine, oddly.

Screenshots of bug splat and temp files generated when opening SketchUp can be found here:

Please help!


Program is being run as administrator

Just downloaded Lego Digital Designer (yes, I’m resorting to digital lego) and now that won’t open either. I’m guessing something MUST connect the three bits of software not opening!

UPDATE 2: Lego runs, when run through the graphics card :slight_smile:

RESOLUTION!: 32bit version works just fine!

Hello Ollie! Welcome to the Forums. :blush: Just a quick suggestion, have you tried running the program as an administrator? Also, others will correct me if I’m wrong but if I’m not mistaken you shouldn’t have deleted the files from the Roaming folder. The files there manage the extensions and plugins.

Hello VP! Very kind!

Thanks for such a quick reply.

My normal password protected account is a/the administrator account.

Oops! Ahh well, too late now. I don’t believe I have any extensions and/or plugins for SketchUp, so thankfully as I only deleted the folder named ‘SketchUp’ in Roaming, I should be ok.

Any other ideas?

So far, none. When I get problems similar to yours, right clicking and choosing Run as Admin usually works for me, so I thought I’d throw that one in as a start. Let’s see what others have to say.

Thanks for trying :slight_smile:

1 Like

SketchUp does not use Java.

Use the Nvidia utility to set SketchUp to use the GTX card and not the integrated graphics. If you continue to get BugSplats! (always send them in, BTW,) uninstall the 64-bit edition and install the 32-bit edition.


You star. 32bit version works :slight_smile: thanks!

1 Like

Just as a footnote, needing the 32-bit version of SketchUp is often an indicator of insufficient graphics card drivers. This isn’t a common complaint with Nvidia, so please make sure that your drivers are updated to the latest version (get from the Nvidia support site).