Sketchup slow beyond specific window size


#1

Here’s an odd one, we’ve found that Sketchup has progressively gotten slower on newer versions on a larger screen (27" 1920x1080). When we ran Sketchup 2013 Sketchup was slow when running full screen, but when run in window mode it was fine. With SketchUp 2014, SketchUp slows down even when running in Window mode. If we have a small window, maybe 1024x768, SketchUp is fast. And then as you expand out the window SketchUp slows down noticeably. It’s almost as if there is a maximum number of pixels SketchUp can support, and isn’t necessarily tied to an aspect ratio. A wide but short SketchUp session is fine, and so is a tall and skinny one. But you can’t seem to expand beyond a certain number of total pixels (1,274,000 in our case, when the window is 1400x910). And you can forget trying to use it at the monitor’s native resolution of 1920x1080, it’s awful. And all this without even loading a model, we’re just using the default scene with the avatar standing there. This occurs on all computers in the office and I’ve checked that the high-end video card (Nvidia Quadro 2000) has plenty of VRAM available and isn’t maxing out GPUs. And, yes, Sketchup’s OpenGL is set to use Hardware Acceleration as is the video card, and upgrading to the latest video drivers doesn’t help either.


#2

@itdgriggs

What processor are you running? It sounds like either your framerate is being limited by your CPU, or you may need to go into the nVidia console and set your performace setting to a higher setting.

~Drew


#3

We’re running on a Xeon E5-1650 3.2 Ghz, plenty fast enough for most things. I also checked the Nvidia application settings but there weren’t anything obviously related to performance in the 20+ application specific settings listed (e.g. vertical sync, stereo, etc,)


#4

@itdgriggs

Do you have the nVidia nView Desktop Manager installed by chance?

~Drew


#5

(I am the user in question)

Yes, nView Desktop Manager is installed, but NOT enabled.


#6

Hi @JoshBrandt

First let’s get the obvious out of the way. Are your nVidia drivers up to date?

If they are, we can move on to the next thing. Please correct me if I am wrong, but the nVidia Quadro 2000 is running 1GB of onboard memory, correct? If this is the case, it would explain the poor performance at higher aspect ratios. High-end cards like the nVidia Quadro series is meant for processing simple things at a large aspect ratio, or very complex things at an aspect ratio of around 1280 X 1024. The short answer is, the graphics card may not be able to keep up with the rigors it is being put through. Depending on how complex you are getting in Sketchup, your video card may be trying to work too hard to process, with only 1GB of onboard. Sketchup can have a ton of faces on a single object. This was an issue I ran into when attempting to import into programs like 3DS Max.

This may be a case where you either need to get a higher end graphics card, or bridge two lower end, to get the aspect ratio performance you are after. I will keep looking and ask a few friends I have that work for nVidia, and see if we can find a different solution.

~Drew


#7

@Drew29, 1GB of memory, yes. Drivers are up-to-date.

@itdgriggs and I had installed GPU-Z to test what the bottleneck was when I was experiencing this slowdown, and the weird thing is that neither the Memory or the GPU are pegged when this behavior is observed (they are about 70%-80% maxed out). This is what led us to assume it was something OpenGL-ish or settings-related, rather than pure physical limits of the graphics card.

If you’re telling me that @itdgriggs NEEDS to buy me a new graphics card, I could get on board with that… :smile:


#8

Hi Josh,

Let’ see if we can save the boss some dough, shall we? :wink:

[Specifications][1] — NVIDIA® Quadro® 2000 mid-range professional graphics solution
Note: Maximum Display Resolution Digital @ 60Hz 2560 x 1600

I’ve run SU on nVidia Quadro FX mid-range cards for seven years.
Currently, two Dell Precision workstations.
The two systems have identical dual monitor configurations and GPU hardware, as follows:
GPU — nvidia Quadro FX 1800 768MB
Monitor 1 — 1920 x 1200 … 230,400 pixels larger than the monitor in question.
Monitor 2 — 1024 x768
Without exception all monitors are run at native resolution and the Anti-Alias in SU is set to 4x
[Specifications][2] — NVIDIA® Quadro® FX 1800 mid-range professional graphics solution

Hmm … Something doesn’t add up here.
Orbiting about Sophie certainly isn’t, “rigorous”.

The Quadro FX 1800 GPUs I’m running are the (weaker) predecessor of the Quadro 2000 in question.
Nonetheless, large/complex models pan, zoom and orbit like butter.
That’s while running two monitors, one of which is 230,400 pixels larger than the monitor in question.

Here’s an example gleaned from a forum topic long ago to illustrate “large/complex” model.
If a Quadro FX 1800 GPU handles this rather ponderous example of modeling mayhem with ease…
Then it might be reasonable to expect a more capable Quadro 2000 will too.

[Store Again.skp][3] … 91.8MB
Here’s a screenshot of the model statistics.

@JoshBrandt @itdgriggs

You might try restoring the card to its default settings and then setup the card and SU as follows:

Clear all program settings for SU

Then, select the 3D setting: Let the 3D application decide

Lastly, confirm the OpenGL settings in SU. Throttle Anti-Alias to suit your taste.
Close and restart SU for the settings to take effect.


[1]: http://www.nvidia.com/object/product-quadro-2000-us.html
[2]: http://www.nvidia.com/object/product_quadro_fx_1800_us.html
[3]: https://drive.google.com/file/d/0B6R273kvdPGOOTEwZDI3ZjAtZWM5NC00ZTJkLWJiNjAtYzNlMjY4ZDY0NzI4/view?usp=sharing


#9

I was having issues with Sketchup 8 and then Sketchup 2015 with my Quadro K600.
I found a solution at the link below. Works for me.
https://productforums.google.com/forum/#!topic/sketchup/HuBB2HxoX8s


#10

IT sounds like an application is waiting to run while waiting for another process to complete and appears to be a function of dispaly resolution used. The challenge then is to find out what that process is. Hopefully the above suggestion may lead to that but if the problem still exist then try starting the task manger, selecting the performance tab, at the bottom of that screen then select the performance monitor. This option is only for windows= /> vista, I am guessing your OS since you did not post that info. This will then bring up several screens giving you much more visibility into performance of your system. If nothing is apparent related to the issue on of those screens select help and then search for wait and then look for wait chain analysis. That will bring up direction how to run that type of analysis. You can then select an application and determine if it is waiting for any other process to complete before it runs.
Just some thoughts, hope it helps??


#11

Hi guys,

I managed to solve the exact same problem by opening sketchup 2015 as administrator. I am not sure why but it seems that doing that solves the problem…

Go into sketchup programme folder and on the exe file right click and assign administrator opening status for the programme…

Good luck!


#12

By saying the exact same problem i mean the original slow beyond specific window size issue…