SketchUp Pro 2015 slow perfomance


#1

Hello,

my customer bought recently a new workstation: Dell Precision T1700.

Main parts are :

Processor Intel® Xeon® CPU E3-1220 v3 @ 3.10GHz, 3101 Mhz, 4 Core(s), 4 Logical Processor(s)

Installed Physical Memory (RAM) 8.00 GB

GPU NVIDIA Quadro K420

When he started to use more robust pictures, SketUp started to slow down rapidly.

What can we do about it? I am quite sure it will involve upgrading parts.


About the SketchUp category
#2

(1) Set SketchUp to use the NVIDIA GPU via the NVIDIA Control panel.

(2) try changing settings in Preferences > OpenGL

(3) Only have the Outliner window open when actually using it.

(4) Model with textures off. Only have textures on when adjusting them, and saving output, rendering, etc.

(5) When modeling, turn off layers that you are not working on.


#3

Be certain Use Maximum Texture Size is disabled. (unless you have good reason to have it on)
Window > Preferences > OpenGL > disable Use Maximum Texture Size


Notice the automatic warning when you turn on Use Maximum texture Size

Best Practice:
Regardless of your GPU’s capabilities; images tax performance.
Limit the image size you bring into SU to 1024 or smaller.


#4

While the graphics card should by and large be OK with SketchUp, it is still one that Nvidia describes as “entry-level”. It might be a bit low key for the workstation you describe, but it should still have better performance than the old QuadroFX 1800 card I use at home quite comfortably.

Anssi


#5

Thank you very much for all your answers, however I went a different way.

I optimised Windows, antivirus etc. spent good 2 hours on it and voila! The computer works smoothly right now!

Anyway, thank you all for your input :).


#6

Well can you share findings on what was causing the slowdown ?

What anti-virus did (or are) you using ? And what changes did you make to stop the slowdown ?


#7

Of course.

  • This computer used SSD drive, therefore I optimised it for SSD drive (simply google Windows SSD optimisation)

  • Antivirus - I excluded page file, SketUp process and SketchUp folder, plus I did exclude SketchUp file extensions. (there is no point to scan for any of these, as this is trusted software)

  • In Windows you disable all unnecessary services and programs they did not need (again, refer to Google for it)

I would like to do even deeper optimisation - in BIOS and driver settings - but I will need to come back to them and share results with you, if successful.


#8

My sketch up was fast with just MAKE soon as I got pro it crashes all the time and is ridiculously slow