Sketchup computer problem

I am having issues with SketchUp that I hope someone can help answer. When a file gets to a certain size on my home computer it become sluggish, slow and long save time or crashing the computer become necessary because it either is taking really long or the program locks up.

I did a test on some files I downloaded from the warehouse a house with trees and a separate file with landscaping. I imported the landscape to the house file on my windows i5 machine at work running windows 7 pro and it worked as it should.

Did the same on my home computer (where I am having the problem) running on Windows 10 pro and a i7 processor and its slow merging the file. Once it shows up and I try to move or rotate its slow at responding. If I go to save it outliner flashes and seems to cycle through each item on the list and its take several minutes to save.

Anybody know what this might be and how to solve it?

my computer specs:
Intel Core i7-5700 CPU@ 4.00 GHz
Ram 16 GB
Windows 10 Pro
x64Bit processor
GeForce GTX 1070

Regardless of how good a computer is, at some model size it will start to lag. The weaker computer, the smaller/less detailed the models need to be for it to work.

At what size (file size and polygon count) do you start getting problems?

1 Like

Keep the Outliner closed when not in use, the more complex the model hierarchy, the more it slows down SU.

1 Like

What version of SketchUp are you using?

Sorry I am on 2018 at home, 2017 at work.
Files size really does not matter. the test file i used from the warehouse are Small+Eco-Cottage.skp and 23.skp both from the cover page.

I dropped both into the same model. My computer specs are lees than yours. Moving, orbiting etc did not affect the performance. I saved it, took about 3 or 4 seconds to process. Is SU tied to your 1070 in the Nvidia control panel?

Not that I know of, is there a way to check?
As far as I know sketchup in CPU based not GPU.

Since the release of SU2017 SketchUp rendering is done by the GPU, not the CPU. There is no option to dump the rendering back to the CPU as in older version where you could turn off Hardware Acceleration.

I will check my Nvidia control panel when i get home tonight.
What am I looking for to change if necessary?

“Manage 3D Settings”

I will check it out when i get home.

Thanks for the information sketch3d_de,

I made the changes you showed and reran the test and it’s a lot better acting, still a little slow. But I’ll work with some of my files over the weekend and see if I have any problems.

Hi: My setting for Open GL rendering GPU is on auto-select. Should I be changing it to GeForce GTX1070? Would that speed up my rendering? Have just purchased iRender nxt 2018 for my SU Pro 2018 version. Barb

When GPU is on auto-select, if your OS decides to go to low-power mode to save energy it will change to the integrated graphics and performance will suffer (and you may get errors or crashes). Set it to always select the GeForce for SketchUp.

just happened to see your previous post - thank you so very much - its been quite sluggish so hoping that it will improve. have a wonderful day. Barb

Sorry for changing to topic - but am also wandering how I can join the live stream with Aaron and Josh today. I got a notice on fb on my cell that there is a sketchup live: operating systems, hardware session on today at 11 am mst? Would love to listen in. I’m in EST timezone.

many thanks…

Just tune into our Facebook page at 1 PM EST and we’ll be live!

thank you … dawwww … I must need another coffee lmao