Troubleshooting stability issues w/ 100mb file


#1

Hi all,

I have a 100mb SketchUp file (~1000’ x 1500’ site model) that is causing my workstation to crash regularly and is slow to navigate around. I’d like some input from the community as to what combination of my workstation, software limitations, and workflow is the likely cause of this and what I can do to improve my workflow that can help reduce file size as well.

File: is made up of 10 SketchUp files that I’ve imported into the model and relink after updating each file invididually. Below is from the model info menu:

Edges: ~2,500,000 (there’s a few flattened CAD underlays, detailed bathymetry and terrain w/ 2’ contours)
Faces: 400,000
Component Instances: 11,000
Groups: 5,600
Component Definitions: 696
Layers: 310
Materials: 462 (Context buildings around site are photo-textured)
Styles: 2
Scenes: 6

Settings: Hardware acceleration is on. Maximum texture size is off. Face style is set to shaded. I change it to shaded with textures when I’m about to export an image. Shadows are off except when I need to export an image.

• Back Edges (off)
• Profiles (on, set to 1)
• Depth Cue (off)
• Extension (off)
• Endpoints (on, set to 1)
• Jitter (off)

Extensions:
•Utilities Tools (SketchUp, loaded)
•FredoLibrary, Tools on Surface, etc. (Fredo6, unloaded)

Hardware: Late 2009 27" iMac. Intel Core i7-860, 12gb 1067MHz DDR3 ram, ATI Radeon HD 4850 512 MB, 1TB SATA drive.

Workflow: I use the outliner menu to organize individual components/groups in each of the 10 files that link into the master. All model information on the same layer. I use layers for toggling on and off survey and site plan reference information. I purge every file twice daily.

Thanks all,

Edit: Added edge style information.


#2

See … SketchUp Hardware and Software Requirements — SketchUp Help


#3

I run a 2007 imac with even lower specs and it’s reasonably stable…

what I have to avoid is ‘AutoSave’ and ‘Save Backup’ as they can they can freeze SU if start while creating complex geometry [e.g. using Fredo’s tools]…

‘Outliner’ can do the same so I close it’s window unless using it directly…

john


#4

What about all the other resource hogs…?
• Back Edges
• Profiles
• Depth Cue
• Extension
• Endpoints
• Jitter


#5

vs.
intel Core i7-860
ATI Radeon HD 4850

time to say goodbye (=> Core i7 w/ dedicated nVidia GeForce)


#6

Geno,

I’ll edit my original post, but to answer your question.

• Back Edges (off)
• Profiles (on, set to 1)
• Depth Cue (off)
• Extension (off)
• Endpoints (on, set to 1)
• Jitter (off)

sketch3d_de,

Getting a new workstation is the easy button solution, but I need to make a case to my employer as to why it’s necessary. That’s why I want to make sure I’m building the model as efficiently as I reasonably can.


#7

Every one of the above settings is a rendering effect that slows performance.
Turn all edge rendering eye candy OFF except Edges.

A compendium of performance modeling tips can be found here…
How do I make SketchUp run faster? — SketchUp Sage Site

A new feature of the SketchUp 2015 Styles Browser is the Fast Style indicator
What are Fast Styles? — SketchUp


#8

You have a number of photo texture materials which can contribute to file size.
If you operate in the monochrome rendering mode does the frequency of crash stay the same?
You can quickly find their affect by saving your materials as a collection. You should then find a skm file which basically is a zip ,but as first check just see what file size ( you do not need to un compress initially ) and see if you have some large contributors. Checking those may lead to some large file size reductions.=> this step will require file extension change to zip so you can extract it.
In addition one can use scenes to navigate the model and help issue with slowness which I did not see any mention in your OP.
I will delete all materials when trouble shooting issue like this to get a sense of material contribution to file size and slowness to help with decision process. => Do only on saved model .
Just some thoughts.


#9

• KB #36235 : Making SketchUp run faster
• KB #161352 : Making SketchUp render faster