SketchUp Shop login

Apologies if this has been asked multiple times. Just upgraded from Free to Shop, but I can’t seem to log into Shop. I keep ending up in Free. Very confusing. Not sure what I’m doing wrong. Long-time SketchUp user. Any ideas? Thanks.

Did you bought the SketchUp Pro subscription or Shop? Did you buy directly? If so, did you check the ‘Automatically assign’ button as well?

Type myaccount.trimble.com in a browser and check to see the plan and if the ‘My Member’ area has the right product assigned.:

SketchUp Shop. Bought directly. I can see Shop in My Products, but I don’t have a pulldown for Personal Account. If I got to Members, Shop shows up as 0/1 available.

watch closely at the gif I posted, Click on the three dots at the end of the row of the email address of the member (probably you:) and choose ‘Modify Product Access’
Then choose the product.

Yeah, thanks, but I did that. Shop and Free are both checked. I can’t uncheck Free. Is that possibly the issue?

No, that’s expected. If you navigate to ‘My Products’ on the left and click on ‘View Included Apps’, then navigate to ‘SketchUp for Web’ and hit launch, it should work.
You weren’t expecting to get access to SketchUp Pro, the desktop client? That’s another plan and is more expensive…

It launches a web app, but I don’t think it’s Shop, because I can’t edit materials, which is an included feature with Shop. I don’t get it.

No, was not expecting to get access to Pro.

What happens when you try to edit materials? Are you trying to edit an in-model material?

Your question got me thinking. I’m good. I just realized that I have to go to “In Model” in order to edit materials. Sorry. Thanks for the help. Long-time user, but always on the old-school offline versions, so this interface is new for me. Not altogether intuitive, but I’ll get there. Thanks again.

2 Likes

The material editing thing, while looking different in Shop than in the desktop versions, works the same in that you can only edit In Model materials. Glad you’ve got it sorted, though.