Materials Editing

I’m using Sketchup Shop for web on Chrome but I can’t edit ANY material even “in model” ones. When I click on “edit material” after material selecting, it shows me a page asking me to update my version to edit materials. I’m sure that Shop version is able to editing materials, right? I’ve already relaunched my Trimble account which shows that my subscription for Shop is active, but it still gives me this information to “update” do edit them.
Are there any suggestions to solve this problem?

It sounds like you aren’t actually using SketchUp Shop. Does the model space have the watermark in the upper right corner? In Shop there will be no watermark.
mats

Try signing out, clearing your browser caches and sign in again.

I looked at your account, and at the moment the subscription isn’t assigned to anyone. Look at this article to see how to assign the seat:

https://help.sketchup.com/en/licensing-accounts-and-administration/managing-sketchup-subscription#add-members

Yes, that was exactly the problem! I’ve just modified my Product Access Options and added the Shop.
Thank you very much

Yes, the watermark was on the screen. I did not know that was the difference between free and Shop versions. I’ve did what I texted in the comment below. Thank you for your reply

That’s one of the differences and makes a quick way to identify which version you are using.

Glad you have it sorted out now.

Hi Dave, I’m experiencing the same problem that GLM had. I don’t see the watermark even though I have the Shop membership. I cleared the caches and signed back in and still don’t see the watermark. The issue may be that I also have the free version and I can’t delete it from my list of products. Either way, please advise.

Not seeing the Watermark is a good thing, the watermark shows in the free version.

1 Like

Ok, thanks. So, why can’t I edit the materials?

Well you have to give us something to go on, a screenshot would help to start with. An explanation of what is and isn’t happening.
Are you unable to click on a material that is in the model then click the edit Icon? Or what? Need some symptoms to work out the problem.

Web Mat

1 Like


Thank you. The editing option is grayed out for me so I can’t use it. Image attached.

Just as in the desktop versions of SketchUp, you can only edit In Model materials. Click on the house icon to get to the In Model materials, select the material and the edit option will be available.

Thank you so very much! It worked. I’m learning on my own so it has been a bumpy road. The SketchUp videos have been a great help!

1 Like

Note I said in my post

and showed clicking the house icon in the gif.

1 Like