Shop version is becoming more dysfunctional by the hour

This program is worse than any prior FREE versions! A very brief list of issues follows: Unable to edit materials, colors and textures. Unable to create reality-reflective shadows, NONE on the ground. Unable to get a simple line, rectangle or circle to stop at a specific entered dimension. Unable to control a non-existent x-ray mode. Unable to control a basic angle degree - similar to geometric shapes. Program doesn’t appear to accept anything input into the measurements field. It’s excessively slow, to the point where a command has to be carried out over again, as if the program doesn’t recognize it. Just curious: Is this Trimble’s way of getting customers to purchase the Pro (Expensive) versions?

None of what you describe matches my experience with SketchUp Shop or SketchUp Free. That makes me wonder what you are doing. How about sharing your model file with us so we can see what you’ve got?


Which browser are you using? From what I hear, Chrome seems to work best with the SketchUp web applications.

Agreed - this isn’t like anything I’ve dealt with with the online version…


Chrome is the browser. If that works best, I fear to find what trouble others are having!


I just might be the exception to the rule. But it’s frustrating!

Try clearing your browser’s cache, deleting the history and cookies.

About the part where you couldn’t edit materials, what happened when you tried that?

You have a Shop subscription with your work email, but still have a Free account with your gmail address. Make sure to be signed in with your work email when intending to use Shop features.

Hi, Colin.
The subscription is with my personal email only.
As for editing materials and components? The icon for the option is inconsistent. It’s either grey-out (non functional); or when available, a pop-out window quickly shows up and disappears. I can see the window offers the option to modify color, texture, etc. But not if it disappears in a fraction of a second!

Thanks, RLGL. But my cache is kept squeaky clean. I use CCleaner regularly and use the Click-and-Clean browser extension for Chrome constantly. So I doubt if there’s some internal interference.

What commands, specifically, are you trying to execute. Even if it may seem slow at times, it shouldn’t require a second attempt to get it done. I have a feeling this might be something you can fix on your end.

You should not be clicking on the measurements box at all, if you are. If you use SketchUp correctly, every line you draw will be as accurate and precise as you desire. Any lack of control you perceive is likely user error.

How are you trying to draw where you fail to achieve precision?

Commands executed: Most of them are failing. Eg - Select. I’ve waited up to 7 seconds for it to respond before repeating the command again. Or Move/Copy. Same thing.

Measurements: Eg - Click on the Line tool. Click on a point in the drawing to start the line. Now if I want a simple dimension like 10 inches, I move the mouse in the desired direction and click 10 in the box. That should set the correct mark on the drawing. Rectangles are the same, but with a double problem. Angles do likewise.

As a footnote: I’ve been using SketchUp off and on since around 2004. I’ve seen the evolution and have worked with its subsequent editions. But now that I’ve finally purchased it, the program has consistently failed.

Hmmm. You should never have to click the box. To draw a ten inch line you click once to start, move the mouse along the axis of your choosing, and then type 10 and hit enter on the keyboard. Maybe you meant to write “type” and not “click.”

Are you saying that it takes 7 seconds after you click on something to select it? Or that it takes several seconds to move something? Is this with any model or a specific one?

Did you have success with previous versions of sketchup drawing accurately and reliably?

I’m entering dimensions just as you relayed, just as I’ve been doing for decades. Still, something is amiss.
And yes, the program has been taking as long as 7 seconds to respond. Something here is also amiss.
Many more issues with this program, too.

I’ve NEVER had any problems with previous (free) versions.

Here’s an example of what I see working in SketchUp Shop. It’s real time although I was deliberately moving slow so viewers would have a chance to see what I was typing in the Measurements window. If you are seeing huge delays in SU Shop I have to think it’s your hardware or the browser version and not SketchUp Shop.

I’d be checking your ‘Unknown’ graphic card and its drivers as it can effect the web version too.
It certainly sounds like an issue up your end since it works for others. I’d also be trying different browsers to help pinpoint where the problem is.

1 Like

Sorry. I corrected that.

Thank you for the demo. All steps appear to be just as I’ve been doing. As mentioned, all worked fine until I purchased this version of SU Shop. I’ve got several computers (Windows 7 and 10). But the program behaves the same on all machines. I’d think that may rule out hardware issues?