Sketchup Scenes Won't Save

Hi everyone,

I was saving scenes for every angle.


Scene 1, hide door
Scene 2, unhide door, hide other side wall.

I was able to make those scene tabs, but the configuration won’t save. If I hide the door in scene 1, then move on to the setup of scene 2, scene 1 will be like the latest (scene 2).

My latest setup will be applied to all the scenes, not making any difference at all.

I hope I make sense.

Please help. Using SKP 2020.


Sound like a common misunderstanding of scenes and geometry.
If you move geometry in one scene it will be moved in the other.
You need to make copies of things and assign them a Tag, then turn them on and off for the appropriate scene.
Simple example of a door, make a copy of the closed door component and rotate it to the open position. Assign each copy a different Tag, Open and Closed for example. Then create a scene for closed and turn off the tag for the open one, make a scene for open and turn on the open tag and off the closed tag.

Hi, I am just hiding some items so it won’t appear in the different scene.

Scene 1. hide door
Scene 2. Unhide door.

When I go back to Scene 1, the door is unhidden again.

Using Hide can be a global setting and so can override your scene settings.
You can adjust what shows when hidden but it is far easier to use tags.
Attach your model for a more specific answer.

Yes, but from what I know,

If you UPDATE the scene, it will save what item should be hidden or not.

If you have set the scene update details correctly.

yes, that’s what I am doing. And I know it should save that scene’s view, but it isn’t doing what I expect it to do.

Don’t know if it will help but these 2 helped me.

It kind of depends on the organization of the model and door component (or group)
If the panel is nested inside a component (door) you actually modify the higher level component.
The same goes for when the frame and panel are just edges, btw
If you ‘enter’ the component in order to hide something, the definition of that Component or Groups get’s modified.
Assuming that a ‘flat level’ organization of the model isn’t the case, you need to use Tags for rhis kind of animation.