Sketchup saving file problem The entity at address 4c83a4e0 has an invalid id (0) destroyed (0)

Results of Validity Check.
*** Problems were found that could not be fixed! ***

The entity at address 4c83a4e0 has an invalid id (0) destroyed (0)

I am getting this problem while saving my project. If you have any idea to solve this please help me.

It should already have been fixed the the message shows up.

1 Like

I’m not very sure how to interprete the message because it happens very rarely. But I understand it as that the erronous entity (that could not be fixed) was removed.

That means the model file is now valid so you should not get the message again when saving next time. Or are you getting this repeatedly, every time you save the model again? Also after a restart of SketchUp (and opening the saved file)?

But it leaves me wondering how the user should be able to verify what entity SketchUp deleted in the model, the consequence could be ignorable but could also be significant (vertices misaligned, or a hole in solid)?

I know one way to create this error: Start a SketchUp model. Model something. Select what you modelled and make it a component. Save the file with the same name as you gave to the component. Now import the file into another SketchUp model. You have created a component definition that references itself.

This is quite common with models posted into the 3D Warehouse, and one of the reasons why you should check everything you download from there before using it in your models.


I’m getting the same error. Since I can’t save it, I can’t upload it, but here’s how I got here: I’d been unable to close a face in a model, no matter what I tried.To try a very simple case, I set four guides and drew a square box. No face was formed. I deleted everything except the square box, and tried to save the box (as test.skp), and received this error message - repeatedly.

So I closed Sketchup (2017), and re-opened test.skp OK. Was also able to repeat my test procedure and make a box, but still no face was formed. But now I can save it so if you can tell me why I can’t form a face, I’ll not worry about the error message. I’m a newbie at this, so I probably did something stupid.
test.skp (137.8 KB)

You don’t suppose the fact you can’t see a face could be due to having the style set to Wireframe, do you?

Change the style to something else or at least set the Face Style to something like Monochrome and you should see the face.Screenshot%20-%208_24_2019%20%2C%204_56_36%20PM

I suspected I did something to screw things up, thanks. Got to read up on the basics some more.

I don’t understand why use white (default color) on white background and in parallel projection. It’s so hard to see what is happening. Of course if it’s set to not show faces at all, that’s even harder, but anyway…it’s 3d and adding a little color can help. Even a horizon line (using a style with sky) can help orient the work.

Part of my problem is I’m using SU for architectural drawings – all 2D. I have dreams of eventually getting the whole thing in 3D, but that’s so far in the future I can’t even imagine it.

1 Like

I see. Well if It is helpful you can set a background color and make it white in scenes to print.

I have had the “validity check error…could not be fixed” multiple times. Usually as a result of importing a component that was not built or saved correctly. If I know which component is causing the issue I change the name in the definition field (found in the entity info tray). The problem will not be resolved until the drawing has been closed and re-opened. The drawing still saves, just without fixing that specific error.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.