Sketchup reading "Cannot Open File" on existing project, then goes to an empty and untitled project

Hi, I’ve been working on a project for a while now. I have my presentation tomorrow morning… I was trying to save my project and transfer to Layout.

Sketchup crashed on me during that process. When I tried to reopen the file it reads “Sketchup cannot open file”. I hit “Ok” then it turns into a blank and unnamed document.

I have been saving it onto an external hard drive. I do have a .skb file but I’m not exactly sure how to open it. My .skp file size is 42,641KB, if that’s necessary information to know.

I’m desperate right now… Please I hope someone can help. I’m freaking out.


If you share the file, there could be a solution. Where you working from an external drive or a cloud?

For the skb part of the question, I would make a copy of that, in case things go wrong, then rename the copy so that it ends with .skp instead of .skp. Then it should open in SketchUp, if it’s not also corrupted.

Hey Colin

Thank you so so much for looking into this. I was able to figure out how to convert my .skb file to a new .skp. That sort of worked… But then considering I was still working from my external hard drive, I tried to put the newly converted file onto my desktop / take it out of my external drive. That seemed to do the trick. Thank you so much!