Unexpected File Format - Help Please!

Hi I’ve been working on a school project for months and suddenly I can’t open it!! I keep getting “unexpected file format”. When I press ok it shuts down SketchUp. If I try to open the skb file it says I don’t have a way to open it. What can I do?? The file is over 17MB so I don’t think I can email it to get fixed?? This was due today and was working fine before. Is there anywhere in Western Australia to take this or can you give me some options to fix it? I purchased SketchUp Pro just so I could do this project!!!
I have Windows 10.
Please Help. Thanks Josh

rename the .skb file extension to .skb.skp and see if it opens…


I tried but I don’t seem to have the option to save as a different file type??

Either directly rename the .skb to .skp by right click on the file in Explorer and select rename and type .skp and accept when it warns you that changing the file extension could cause problems.
Then see if it opens.


Open a blank sketchup and import the .skb file into it.

Thank you thank you thank you! You have saved my life!! Changing to skp & renaming worked.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.