Sketchup Pro 2018 - Unexpected file format

error
unexpectedfileformat

#1

To All,

I am having an issue opening my file. It was working fine yesterday but when i tried to open it today it comes with message

“Unexpected File Format.”

I am a university student and have spent sever of hours work on this submission which is due very soon any help would be much appreciated!

If anyone could take a look the link to file here on google drive (01 Entire project.skp 104mb).

https://drive.google.com/open?id=1tccljJg_25UP4-2GgIbyXC3CrTDGa0Zy

Similar issue to:

Sketchup didn’t provided me with a backup (skb file) so I couldn’t try the method of changing file name extension.

Using windows 10 64 bit, Sketchup Pro 2018 (trial)

Any help would be much appreciated to getting this file working, Thanks in advance!

Regards,
Krystal


#2

Hi,

I’m sorry to say that you’re file doesn’t open on my computer either.

I’ve looked through the other thread in an attempt to learn something about this… and have had a small bit of success in trying to open this file via the ruby command line.

I don’t imagine that what I have is too useful here since the file size is anemic compared to what you’ve uploaded onto your google drive.

What does show up are a few initial components,… which unfortunately don’t appear refined enough to match what’s shown in the file preview picture.

But for what it’s worth, this is what I have so far… Entire Project Test (JD Alt).skp (241.3 KB)

I’ll keep trying here. maybe I can improve upon things.

And perhaps since I’ve made some progress, there’s a chance that others around here—who are more experienced at this sort of recovery stuff—can get even better results.

Question:

When is your project due?


#4

Thanks JimD,

Thanks for trying to help me out and sharing your story, providing some light in this very dark tunnel.

Unfortunately the file you uploaded wasn’t able to recover much but appreciated for your help.

It is due on the 15th this coming Friday.

Regards,
Krystal


#5

How frustrating for you. I downloaded it just to see if randomly it would open up but it wouldn’t. I can however, see the thumbnail in the file explorer which is very tantalising.

I really hope you get it back.

Have you tried going back into the temp files to see if there’s an older version hanging about?


#6

How do you know? Was backups disabled? Is your documents folder set to show all files? Set the folder to display file extensions and show hidden files.


#7

My sympathies, I know the feeling - like when my hard drive blew up and took all my work with it. Have to say JImD loved your witty, wise and beautifully told story.


#8

Sometimes when the file says .skp, it’s actually using a different extension. Try checking the file info where it lists the extension.


#9

Yeah it was disabled, not sure why it was. My other projects had backup files.(have turned it on now). No hidden files. Thanks


#10

Thanks, but had no luck so far. Could not see any temp files for an older version hanging.


#11

Tried to name it different file extension to open it up but no luck and check the list extension it is a .skp (sketchup model).

image


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.