Sketchup Pro fails to export DWG/DXF

Ik want to Export a 3d model in DXF or DWG format but Sketchup stops every time I try.

  • the same model exported to DWG and DXF before, but now it fails
  • The same model still exports to IFC
  • I run SU pro on a Mac.
  • I tried purging unused, which was a suggestion form another topic here.

Is this a known problem? and more important: is there a way to solve this?

you have surely restarted your system already?

do all documetns even simple ones cease to export?

you may want install/run ThomThoms CleanUp³ plugin (“Window > Extension Warehouse…”).

You might have a corrupt SketchUp Preferences file, and deleting it would force SketchUp to create a new, clean one. I don’t use a Mac, so I cannot tell you where to find the file.

On Mac it is called :
com.sketchup.SketchUp.2017.plist
it is located in :
Macintosh HD/Users/Username/library/Preferences

the library folder is hidden, so , in Finder-> Go->Go to Folder and type destination

Gebruik je de 3D Model optie of 2D Graphic?
Are you exporting the 2D graphic or 3D Model ? How large is the file ?
Like @sketch3d_de suggested :

  • Close SketchUp ( You are on a Mac, make sure all instances are closed )
  • Open a new File ( and the next three steps are to ensure you haven’t got a corrupted template : )
  • select all ( cmd a ) en delete all ( BackSpace )
  • WIndow->Model Info->Statistics
  • Purge unused
  • draw some geometry ( een simpel zonnepaneel oid)
  • Probeer Try to export this simple file

Does this work ?

Thanks for thinking with me.

System is restarted. I couldn’t find the preferences file (even with the hints from Mike) but I found out that, with another simple cube I can export a 3d dwg file. SO it seem to be that the problem is in the geometry.

What I could do is save a copy, then deleted components one by one and try exporting again after every deletion to find out where the error is.

This can be simple, or can be time consuming. good idea?

Or the amount.How large is your SU file ? Can you share it here ? Are there any 3D warehouse components ?
Try deleting half the number of components.

The file is 3MB in size. The whole exercises is to make models of our products available for customers on different platforms. So there is no problem sharing it here. Although it is not finished yet.

Sunbeam modellen.skp (2.8 MB)

I couldn’t find anything strange, but maybe one of you does. I think deleting geometry one by one to find out where the error is, is the way to go now.

With this relatively small file it isn’t a big deal. For larger files it would be good to have a more efficient way to find where te error is.

I think I have found the culprit, there was an unnamed definition. After renaming it and toggled some options on in the export , it exported fine.

Here is the file :
Sunbeam modellen1.skp (646.5 KB)

and the export :
Sunbeam modellen1.dwg (664.5 KB)

have fun! (in the …)

2 Likes

The “outliner” window is useful. Never found it before. Thanks!

In the end I had to delete the piece of 3D text you found and then the model exported again. Thanks for the help!

Strange thing is: I redid the 3D text which was deleted. In the original model it shows 1 component in the model. When exported to DWG it makes 3 instances of that component at random places in the model. No idea why.

Export report said all is fine. Maybe Skecthup is fine with randomly distributing components in my model, I am not so fine with it actually.

It’s not that this model is so complicated. Is SU’s dwg conversion so buggy? or am I doing something wrong?

Wait: i will share the doc’s again:
original SU model: Sunbeam models.skp (680.8 KB)
model after export to DWG and import to SU again. Sunbeam models -DWG import .skp (575.5 KB)

there are a few thing I can 't solve:

  • the “universal 1270” text appears 3 times. Somehow its made a group of it and combined another component (Sunbeam Nova Symmetrical 2100 ) to it. ??? At least i know how to figure that out now I know the Outliner window :slight_smile:
  • Colours change: from the extruded objects, all stays well. From the unextruded objects the colour changes. Why do they change and why so randomly? some do, some don’t, some turn grey, other turn yellow and even pink?

Edit:
i tried fixing the first Bug so at fist deleted the “universal 1270” 3D text block. and then… The other component (Sunbeam Nova Symmetrical 2100 ) which never had an issue but somehow got into a group with the 3d text, now is connected to… another piece of 3d text?! I am completely in the dark here.Why does SU randomly makes groups when exporting to DWG? Sunbeam models -DWG import 2 .skp (459.1 KB)

Glad it worked !
When you redid the component, did you purge the model first ? Sometimes the ‘internal database’ of the entities (Component definitions etc) in Model need to be cleaned up. I frequently purge the model when making components, renaming, etc to keep the file ‘clean’. Remember : every component you ever made or imported is still in the ‘In Model collection’ in the component tray. Window->Model Info->Statistics purge unused takes care of that. Or click the little detail icon in the components tray.

Edit : by default, 3D text comes in as a Component with the text as Definition and Description. So , especially when you are on a Mac and try to edit the Definition’s name in the entity info, you could wind up with ‘nameless’ definitions…

Hy Mike,

Since I found the purge unused button I purge all day long :slight_smile:
Now I redraw the “Sunbeam Nova Symmetrical 2100” component (purging before and after) :stuck_out_tongue: and now that part is fixed. All text blocks are exported and no strange random groups are made. I am still curious how this occurred, but anyway: for now it is good it’s solved.

Then there is still the colour issue. Any ideas?

Most likely you are aplying colors on the ‘Back’ side of the face. SketchUp is a (flat) surface modeler and a face has two sides : Front and Back. In the standard templates, the front is white and the back is grayish blue. If you are drawing a face on the ground plane, its normal is down, so we are looking at the back of the face ( the inside of a box, when the face is pulled up) With the export reversed faces it is likely that things turned bad…

In Sketchup, edit component, right click on face and choose ‘reverse faces’ then apply color.

Notice when you have 3D text set to 0 extrusion , the faces of the text are also reversed.

Most of the time , I have set the back face color to a more distinctive one like orange or green in my style settings …

The next step would be to put the different representatives of your components on their own layers. Then Put them all together for one product and make a ‘shell’ component. This Shell component can be applied with different attributes in the Dynamic component attributes dialog. Things like price, availability ,website urls, etc can be added and seen by the user or listed in generated reports.

haha, that last part sounds one level up for me :slight_smile:

I know the reverse faces function and was busy reversing them to get a good export. Result:

  • All faces are exported the same (altough not yet correct, at least they are the same)
  • but AGAIN SU started making groups of components and so unnecessary copies. In this case: “Sunbeam Nova Symmetrical 2100” was made a part of a group with a component called " wind plate" so now everywhere where there was a wind plate there now is a wind plate AND a “Sunbeam Nova Symmetrical 2100” an every where there was only a “Sunbeam Nova Symmetrical 2100” now is also a wind plate.

This is super annoying. How on earth is it possible that a file exports correctly, that i change faces of component A and on a new export SU messes up component B and C

The problem must be in the “Sunbeam Nova Symmetrical 2100” component, although i completely remade it already. And I know it is probably my fault. But it is super annoying that there is no way to find out what is wrong.

Edit: i have redrawn the “Sunbeam Nova Symmetrical 2100” component again. And luckily everything exports again without making strange groups. Men I would be happy to find out what happened here. And how to prevent it from happening again.

Thanks to many advice here the file is now ok for export to DWG. Ik took me a few versions an attempt. but: cool! thanks.

Now the next step: export to IFC. new topic for that. (and is Mike’s last comment not already the beginning of that?)

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.